[R-SIG-Mac] R segfault at startup, causing R crash

Bryan Hanson hanson at depauw.edu
Sat Nov 5 01:16:02 CET 2016

I had something similar earlier this week (also on Sierra).  I was in touch with Simon who suggested it might be a bad workspace image, so you can try to remove any .RData or .rda files.  However, in my case it was not that (I don’t save workspace images or histories for that matter).  But I removed all of those from my entire computer anyway and the problem remained (a few were left on shared drives by others who were saving workspace images).

Ultimately I was able to trace the problem to something being wrong with the “recent” list.  In my case R.gui was trying to open the most recent file in the list, but something about the link to it was corrupted.  I verified this by running R from the command line and sourcing the file that seemed to be associated with the crash.  It worked fine, so the file was not the problem.

So, here’s what worked for me: When R.gui is asking you for a “selection” to close down, see if the File -> Open Recent… option can still be selected, and if so, go all the way down to the clear menu item.  Once this list of recently opened files was empty, R.gui ran fine.  In my case not all files would clear from the list.  There was one left, and it was the one apparently causing the problem.  I renamed it so R.gui couldn’t use it/find it, and then the problem was gone.  Again, there was nothing wrong with the file, there was something wrong with the “remembering”.

A few days later, I had to repeat this process when the problem re-occurred.  There may be something genuinely conflicted between Sierra and R.gui, only time will tell.  If it proves to be a widespread problem more observations should help narrow it down.  But this is what I experienced and how I fixed it.


> On Nov 4, 2016, at 7:31 PM, C W <tmrsg11 at gmail.com> wrote:
> Dear R list,
> Every time I start R, the following error message come up:
> *** caught segfault ***
> address 0x0, cause 'unknown'
> Possible actions:
> 1: abort (with core dump, if enabled)
> 2: normal R exit
> 3: exit R without saving workspace
> 4: exit R saving workspace
> Selection:
> Sometimes I get this error message instead,
> 2016-11-04 16:50:08.446 R[23372:326103] -[NSDrawerWindow
> setRuleThickness:]: unrecognized selector sent to instance 0x7fabc94a74b0
> 2016-11-04 16:50:08.454 R[23372:326103] *** RController: caught ObjC
> exception while processing system events. Update to the latest GUI version
> and consider reporting this properly (see FAQ) if it persists and is not
> known.
> *** reason: -[NSDrawerWindow setRuleThickness:]: unrecognized selector sent
> to instance 0x7fabc94a74b0
> *** name: NSInvalidArgumentException, info: (null)
> *** Version: R 3.3.2 (71607) R.app R 3.3.2 GUI 1.68 Mavericks build
> Consider saving your work soon in case this develops into a problem.
> Here's the sessionInfo(),
>> sessionInfo()
> R version 3.3.2 (2016-10-31)
> Platform: x86_64-apple-darwin13.4.0 (64-bit)
> Running under: macOS Sierra 10.12.1
> locale:
> [1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8
> attached base packages:
> [1] stats     graphics  grDevices utils     datasets  methods
> [7] base
> I would appreciate any help,  thank you!
> 	[[alternative HTML version deleted]]
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list