[R-SIG-Mac] R crashes when using edit() or fix()

David Winsemius dwinsemius at comcast.net
Tue Jan 26 20:29:27 CET 2016

> On Jan 26, 2016, at 10:38 AM, Simon Urbanek <simon.urbanek at r-project.org> wrote:
> Please try the latest version from
> http://r.research.att.com/

Is anyone else experiencing being locked out of /r.research.att.com/? I have no difficulty  getting packages from most CRAN repos but on all three browsers I have tried I get a message saying "Waiting for r.research.att.com/" and a blank browser screen remains util it times out.

> as there was a bug fixed recently that appears related
> https://bugs.r-project.org/bugzilla/show_bug.cgi?id=16561

I'd like to update my GUI and thought I did so earleir this week but my logon display says I still way behind the GUI version r7108 in that bug fix notice from months ago. I'm still seeing this on booting R:

R.app GUI 1.66 (7060) x86_64-apple-darwin13.4.0

Thanks for any insights or theories;

> Cheers,
> Simon
>> On Jan 26, 2016, at 1:30 PM, Kamila Naxerova <knaxerova at partners.org> wrote:
>> Dear list,
>> For quite a while, I haven’t been able to use the edit() or fix() functions on a data frame without R crashing instantaneously. I am running OS X El Capitan, I have the newest versions of Xcode (7.2) and XQuartz (2.7.8). I just installed “Wooden Christmas-Tree", hoping that this problem — which has been bothering me for about a year perhaps, but seemed avoidable enough  -- will go away with the new version, but it persists. 
>> Unfortunately, I cannot paste an exact error message because the new R version does not produce one, it just freezes indefinitely. The freezing happens AFTER the data editor window popped up correctly. When I try to close it, everything comes to a standstill. With “Smooth Sidewalk”, I would usually get something along the lines of “memory not mapped” and then the usual options 1: abort (with core dump, if enabled), 2: normal R exit etc.
>> This problem does not occur when using edit/fix on simple vectors or strings, it’s just when the data editor gets evoked for a data frame/matrix edit that everything goes down the tubes.
>> Could somebody please help point me in the right direction? Sorry if I am overlooking something obvious. I googled around, searched on mailing lists many times and tried different solutions that were offered for similar problems, but I can’t seem to get it done correctly.
>> platform       x86_64-apple-darwin13.4.0   
>> arch           x86_64                      
>> os             darwin13.4.0                
>> system         x86_64, darwin13.4.0        
>> status                                     
>> major          3                           
>> minor          2.3                         
>> year           2015                        
>> month          12                          
>> day            10                          
>> svn rev        69752                       
>> language       R                           
>> version.string R version 3.2.3 (2015-12-10)
>> nickname       Wooden Christmas-Tree 
>> Thanks so much.
>> Kamila
>> The information in this e-mail is intended only for =...{{dropped:11}}

More information about the R-SIG-Mac mailing list