[R-SIG-Mac] (no subject)

David Winsemius dwinsemius at comcast.net
Fri Oct 24 19:12:18 CEST 2014

The Java section of the Admin Guide currently reads:

"Check if a JRE is installed by running java -version in a Terminal window: if Java is not installed this should prompt you to install it.

However, you may want/need to install the latest Java from Oracle (currently Java 7 fromhttp://www.oracle.com/technetwork/java/javase/downloads/index.html); this is for Lion and later."

When I upgraded to Yosemite (from Snow Leopard), I installed the Jave SE development kit from:


I was informed that Java 7 in Yosemite is not supported and that Java 8 is required. From Terminal session I run:

$ java -version

### I get:

java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

### And when I run:
$ /usr/libexec/java_home -V -a x86_64

### Iget

Matching Java Virtual Machines (1):
    1.8.0_25, x86_64:	"Java SE 8"	/Library/Java/JavaVirtualMachines/jdk1.8.0_25.jdk/Contents/Home


### I then ran:

R CMD javareconf

### and after some compiler messages I eventually see:
…omitting several lines
Java home path   : /Library/Java/JavaVirtualMachines/jdk1.8.0_25.jdk/Contents/Home/jre
…. omitting several more, then...
Updating Java configuration in /Library/Frameworks/R.framework/Resources

I hope this means I’m "good to go” and that I do not need make further efforts at setting environment variables.


David Winsemius, MD
Alameda, CA, USA

More information about the R-SIG-Mac mailing list