[R-SIG-Mac] Cairo / X11 problem in Mavericks

Simon Zehnder szehnder at uni-bonn.de
Sun Oct 27 21:19:22 CET 2013


take a look in your Ressources/etc/Makeconf and your /.Renviron file and search for cairo. There is possibly a ‘stale’ path such that R is searching for a path that existed in ML but not in Mavericks. Check the path via locate in your shell. 

Maybe it helps then, if you install the new Xcode developer tools for Mavericks via Xcode -> Xcode Developer Tools -> More Xcode Developer Tools.

Just a guess


On 27 Oct 2013, at 20:45, Jeroen Ooms <jeroen.ooms at stat.ucla.edu> wrote:

> I just upgraded my macbook to maverick and i'm running into an old problem.
> When I do:
> png(tempfile(), type="cairo")
> or
> svg(tempfile())
> or even:
> library(Cairo)
> R exists with a warning that X11 is required. I also tried:
> options(bitmapType = 'cairo')
> png(tempfile())
> but same result. If I recall correctly this was not the case in OSX 10.8.
> Is there any way to use png() or svg() on Mavericks without installing
> xquartz?
> 	[[alternative HTML version deleted]]
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list