[R-SIG-Mac] Same code, working with R.app Mac GUI 1.61 (R 3.0.1), not with R 3.0.1 from terminal

peter dalgaard pdalgd at gmail.com
Wed May 29 15:58:06 CEST 2013

You're giving us essentially nothing to go on, but I'd try running under a debugger (R -d gdb), hit ctr-C and look at a backtrace, to see where it is getting stuck. Or connnect gdb to the running process with "gdb -p PID".


On May 29, 2013, at 15:12 , Nathan Uyttendaele wrote:

> Hello,
> I have a very peculiar problem to share.
> I wrote a (rather) large R function that also includes some C code.
> When I run it with R.app Mac GUI 1.61 (R 3.0.1), no problem at all.
> When I run it from R 3.0.1 from terminal (on the same Mac), I get the
> output of the function, and that output is fine, the prompt appears but
> when I submit a new command, nothing happens and the processor keeps on
> running even though no calculations are necessary.
> 	[[alternative HTML version deleted]]
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

Peter Dalgaard, Professor
Center for Statistics, Copenhagen Business School
Solbjerg Plads 3, 2000 Frederiksberg, Denmark
Phone: (+45)38153501
Email: pd.mes at cbs.dk  Priv: PDalgd at gmail.com

More information about the R-SIG-Mac mailing list