[R-SIG-Mac] rgl segfault

Roger Koenker rkoenker at illinois.edu
Wed May 8 22:43:01 CEST 2013

Is there some new protocol for installing rgl?  I finally installed R 3.0 today:

> require(rgl)
Loading required package: rgl
> sessionInfo()
R version 3.0.0 (2013-04-03)
Platform: x86_64-apple-darwin10.8.0 (64-bit)

[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] rgl_0.93.935

and installed rgl from binaries....  but rgl.open()  yields:

> rgl.open()

 *** caught segfault ***
address 0xe8, cause 'memory not mapped'

 1: .C(rgl_dev_open, success = FALSE)
 2: rgl.open()

I had an old note to myself suggesting to install from source with:

R  CMD INSTALL --configure-args="--x-includes=/usr/X11/include --x-libraries=/usr/X11/lib" rgl

which I tried too, but it produced the same result when I tried to run demo(rgl).  Any suggestions
would be welcome.


url:    www.econ.uiuc.edu/~roger            Roger Koenker
email    rkoenker at uiuc.edu            Department of Economics
vox:     217-333-4558                University of Illinois
fax:       217-244-6678                Urbana, IL 61801

More information about the R-SIG-Mac mailing list