[R-SIG-Mac] [R] problem with the installation of r commander on a mac

John Fox jfox at mcmaster.ca
Thu Oct 4 22:32:37 CEST 2012

Dear Marco,

To provide some background, you and I have corresponded about your problem,
and now at least you appear to have the tcltk package installed. Did you
reinstall R as I suggested?

Have you checked that tcltk is working, following the instructions I sent
you in an earlier email?

I don't believe that the Rcmdr ever calls tk_messageBox directly, but there
is a tk_messageBox() function in tcltk, and you can check whether this is
the source (or a symptom) of the problem by issuing the following commands
in a fresh R session:


That should, as the function name suggests, bring up a Tk message box.

Also I'm not sure what's going on with 'couldn't connect to display ":0"',
which suggests an X-Windows issue.

Finally, I'm moving this discussion to r-sig-mac, where you're more likely
to get knowledgeable assistance.


John Fox
Senator McMaster Professor of Social Statistics
Department of Sociology
McMaster University
Hamilton, Ontario, Canada

> -----Original Message-----
> From: r-help-bounces at r-project.org [mailto:r-help-bounces at r-project.org]
> On Behalf Of Marco Mello
> Sent: Thursday, October 04, 2012 12:57 PM
> To: r-help at r-project.org
> Subject: [R] problem with the installation of r commander on a mac
> Dear list members,
> Im trying to install R Commander under Mac OSX Mountain Lion (10.8.2).
> After following all the steps described in the installation notes
> (http://socserv.socsci.mcmaster.ca/jfox/Misc/Rcmdr/installation-
> notes.html), I got this error message:
> =====
> Loading required package: tcltk
> Loading Tcl/Tk interface ... done
> Loading required package: car
> Loading required package: MASS
> Loading required package: nnet
> Error : .onLoad failed in loadNamespace() for 'Rcmdr', details:
>   call: structure(.External("dotTclObjv", objv, PACKAGE = "tcltk"),
> class = "tclObj")
>   error: [tcl] invalid command name "tk_messageBox".
> In addition: Warning message:
> In fun(libname, pkgname) : couldn't connect to display ":0"
> Error: package/namespace load failed for Rcmdr
> =====
> The strange thing is that Ive installed Tcl/Tk and XQuark as
> recommended.
> Ive also tried uninstalling R, reinstalling the latest version (2.15.1
> signed) and all packages, and following the same official steps again.
> It didnt work neither.
> Could you please help me? R Commander always worked fine on my iMac,
> until I updated to Mountain Lion.
> Best regards,
> Marco
> ************************
> Prof. Dr. Marco A. R. Mello
> Universidade Federal de Minas Gerais
> ICB - Depto. Biologia Geral
> http://marcomello.casadosmorcegos.org
> marmello at gmail.com
> ************************
> 	[[alternative HTML version deleted]]

More information about the R-SIG-Mac mailing list