[R-SIG-Mac] building a package on a Mac: pdflatex

Federico Calboli f.calboli at imperial.ac.uk
Tue Jul 5 15:10:20 CEST 2011


> both are entirely irrelevant - run
> system("pdflatex --version")
> in R - that is the only thing that counts. If it shows an error, then you don't have pdflatex on your PATH which would be the problem. As a side note, you are showing two separate TeX packages which may not help you to find out what breaks in your setup in general ...

thanks for the hint. Unfortunately:

system("pdflatex --version")
/bin/sh: pdflatex: command not found

doing a simple


fixed it if I use R and package.skeleton() from the terminal. If I use the R gui (from the standard R 2.13.0 CRAN download) it still does not find pdflatex and does not build a usable package skeleton.

In any case, your hit solved my issue. Now, how do I set the path for the R gui?



Federico C. F. Calboli
Department of Epidemiology and Biostatistics
Imperial College, St. Mary's Campus
Norfolk Place, London W2 1PG

Tel +44 (0)20 75941602   Fax +44 (0)20 75943193

f.calboli [.a.t] imperial.ac.uk
f.calboli [.a.t] gmail.com

More information about the R-SIG-Mac mailing list