[R-SIG-Mac] arules installation

Thomas Chesney Thomas.Chesney at nottingham.ac.uk
Wed Dec 7 12:05:13 CET 2011

I sent the following and got the following reply to the R-Help, and then was told I should have sent it here.

On 07.12.2011 10:54, Thomas Chesney wrote:
>   I'm using R version 2.13.0 (2011-04-13) on Mac OS X and I get the following error message with library(arules):
> Loading required package: Matrix
> Loading required package: lattice
> Attaching package: 'Matrix'
> The following object(s) are masked from 'package:base':
>      det
> Error in dyn.load(file, DLLpath = DLLpath, ...) :
>    unable to load shared object '/Library/Frameworks/R.framework/Versions/2.13/Resources/library/arules/libs/i386/arules.so':
>    dlopen(/Library/Frameworks/R.framework/Versions/2.13/Resources/library/arules/libs/i386/arules.so, 6): Library not loaded: /Library/Frameworks/R.framework/Versions/2.14/Resources/lib/libR.dylib
>    Referenced from: /Library/Frameworks/R.framework/Versions/2.13/Resources/library/arules/libs/i386/arules.so
>    Reason: image not found
> In addition: Warning message:
> package 'arules' was built under R version 2.14.0
> Error: package/namespace load failed for 'arules'

Install an arules binary that was built for your version of R (reather 
than a later one) or install from sources.

Uwe Ligges

> The arules CRAN page says: Depends:   R (≥ 2.11.0), stats, methods, Matrix (≥ 0.999375-38), all of which I have - anyone know what the problem is? I'm really relunctant to update R as its Package Installer is blocked somehow by our Firewall and updating all the packages I use is a major hassle.
> Thank you (as always!)
> Thomas
> PS on a related note, are the package installer port settings available somewhere and I'll send them to IT, ask them to unblock it?


I tried installing from source as Prof Ligges suggested (as explained here: http://stackoverflow.com/questions/1474081/how-do-i-install-an-r-package-from-source) but got the following error:

install.packages("/Users/thomas/Documents/arules_1.0-7.tar.gz", repos=NULL, type="source")
* installing *source* package ‘arules’ ...
** libs
*** arch - i386
sh: make: command not found
ERROR: compilation failed for package ‘arules’
* removing ‘/Library/Frameworks/R.framework/Versions/2.13/Resources/library/arules’
Warning message:
In install.packages("/Users/thomas/Documents/arules_1.0-7.tar.gz",  :
  installation of package '/Users/thomas/Documents/arules_1.0-7.tar.gz' had non-zero exit status

Why would installing from source make any difference? Prof Ripley suggested I use arules for R.13.0, which I would if I could find it.

Has anyone got any advice?

Thank you,

This message and any attachment are intended solely for the addressee and may contain confidential information. If you have received this message in error, please send it back to me, and immediately delete it.   Please do not use, copy or disclose the information contained in this message or in any attachment.  Any views or opinions expressed by the author of this email do not necessarily reflect the views of the University of Nottingham.

This message has been checked for viruses but the contents of an attachment
may still contain software viruses which could damage your computer system:
you are advised to perform your own checks. Email communications with the
University of Nottingham may be monitored as permitted by UK legislation.

More information about the R-SIG-Mac mailing list