[R-SIG-Mac] Oops --- still have problems building R from source.

Berend Hasselman bhh at xs4all.nl
Thu May 27 16:56:18 CEST 2010

On 27-05-2010, at 01:20, Rolf Turner wrote:

> On 27/05/2010, at 12:37 AM, Simon Urbanek wrote:
> 	<SNIP>
>>>> mv /sw /sw.notused
>>>> and edit your Bash .profile to NOT source the init script of Fink (If I remember correctly).
>>>> Because that's how the Fink include and lib paths are activated and how Fink modifies your PATH. (I think).
>>> Tried that.  And I get
>>> make[3]: *** No rule to make target `/sw/include/iconv.h', needed by `sysutils.o'.  Stop.
>>> make[2]: *** [R] Error 2
>>> make[1]: *** [R] Error 1
>>> make: *** [R] Error 1
>>> So somehow it is still looking for /sw even though I moved /sw aside and took the call to
>>> the init script out (of my .cshrc, actually).
>>> Any other ideas?  Sorry for all the bother.
>> Are sure you cleaned up your build (i.e. removed the whole build directory) before configuring?
> I'm not sure of *anything* since I don't understand the subtleties of the procedure @ all.
> What I did was *remove* the directory created by untarring the R tarball.  I then
> unpacked the tarball again, made the requisite edits to config.site, moved
> /sw aside, took the line referring to /sw/bin/init.csh out of my .cshrc file,
> did ./configure (that worked!) and then did ``make''.
> Wound up getting:
>>       .
>>       .
>>       .
>> gcc -arch x86_64 -std=gnu99 -dynamiclib -Wl,-headerpad_max_install_names  -undefined dynamic_lookup -single_module -multiply_defined suppress -L/usr/local/lib -o R_X11.so dataentry.o devX11.o rotated.o rbitmap.o -lSM -lICE  -lX11 -lXt -lXmu   -L../../../lib -lR   -Wl,-framework -Wl,CoreFoundation
>> ld: library not found for -lSM
>> collect2: ld returned 1 exit status
>> make[4]: *** [R_X11.so] Error 1
>> make[3]: *** [R] Error 2
>> make[2]: *** [make.X11] Error 2
>> make[1]: *** [R] Error 1
>> make: *** [R] Error 1
> What is the ``-lSM'' business all about?  What is ``SM''?  How do
> I get the missing library?  Psigh!  :-(

You had the same thing some iterations ago.
-lSM  tells the linker to link against libSM.dylib (in this case; because of the -dynamiclib if i am correct).
This .dylib is in /usr/X11/lib

You may have forgotten to  put the line


into the config.site file.

I can't think of anything else.


More information about the R-SIG-Mac mailing list