[R-SIG-Mac] problems with X11 in R 2.11.0

Seth Schommer scschommer at gmail.com
Thu Apr 29 23:59:22 CEST 2010

I installed R 2.11.0 today and immediately came across an issue I did
not experience using version 2.10.1.  For some reason, I can not use
X11 in R.  Here's a simple example:

> X11()
Error in X11() : X11 module cannot be loaded
In addition: Warning message:
In X11() :
  unable to load shared library
6): Library not loaded: /usr/X11/lib/libpng12.0.dylib
  Referenced from:
  Reason: Incompatible library version: R_X11.so requires version
42.0.0 or later, but libpng12.0.dylib provides version 36.0.0
> sessionInfo()
R version 2.11.0 (2010-04-22)

[1] en_US.UTF-8/en_US.UTF-8/C/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

I'm running Mac OS X 10.5.8.  This error occurs when running R.app and
while running R from the terminal.  After experience this I
reinstalled 2.10.1 and tried the same command and had no problems.
Just to make sure, I installed 2.11.0 again, and sure enough, I got
the same error.  Is this a bug, or have I done something wrong?



More information about the R-SIG-Mac mailing list