[R-SIG-Mac] R CMD check fails on Snow Leopard

Kasper Daniel Hansen kasperdanielhansen at gmail.com
Thu Apr 29 05:25:49 CEST 2010

You can have a look at the library by doing file (otool is also nice
to know btw), I get

# file affxparser.so
affxparser.so: Mach-O 64-bit dynamically linked shared library x86_64

You do this on both the ROOT library and the xps.so library to see
what the architectures are.  Based on the error message, they are
different.  Why, is something I think you will have to track down
yourself, because that depends on how you compiled R/ROOT.


On Wed, Apr 28, 2010 at 5:54 PM, cstrato <cstrato at aon.at> wrote:
> Dear Simon,
> My package is "xps" which has always worked on Tiger and also on Leopard,
> thus I am shocked that it does not work on Snow Leopard. The problem is not
> only that I cannot do "R32 CMD check xps-1.9.0.tar.gz" which results in the
> error message mentioned, but that the binary which I have downloaded using
> "biocLite("xps")" gives me the same error message.
> When I start "R32" which I need to do since I have compiled the ROOT
> framework for 32 bit, I get:
>> library(xps)
> Error in dyn.load(file, DLLpath = DLLpath, ...) :
>  unable to load shared library
> '/Users/rabbitus/Library/R/2.11/library/xps/libs/i386/xps.so':
>  dlopen(/Users/rabbitus/Library/R/2.11/library/xps/libs/i386/xps.so, 6):
> Library not loaded: @rpath/libCore.so
>  Referenced from:
> /Users/rabbitus/Library/R/2.11/library/xps/libs/i386/xps.so
>  Reason: no suitable image found.  Did find:
>        /Volumes/CoreData/ROOT/root/lib/libCore.so: mach-o, but wrong
> architecture
>        /Volumes/CoreData/ROOT/root/lib/libCore.so: mach-o, but wrong
> architecture
> Error: package/namespace load failed for 'xps'
> At the moment I have no idea what might be the reason for this:-(
> Best regards
> Christian
> On 4/28/10 11:38 PM, Simon Urbanek wrote:
>> On Apr 28, 2010, at 5:22 PM, cstrato wrote:
>>> Dear all,
>>> Last week I have installed on my MacBook Pro Snow Leopard 10.6.3 and
>>> downloaded from Apple Xcode 3.2.2. Then I have installed R-2.11.0.pkg for
>>> Mac OS X 10.5 (Leopard) and higher.
>>> Now I wanted to run R CMD check for my BioC package which contains C++
>>> code but got the following error:
>>> installing to /Volumes/CoreData/CRAN/xps.Rcheck/xps/libs/i386
>>> ** R
>>> ** inst
>>> ** preparing package for lazy loading
>>> ** help
>>> *** installing help indices
>>> ** building package indices ...
>>> ** testing if installed package can be loaded
>>> Error in dyn.load(file, DLLpath = DLLpath, ...) :
>>>  unable to load shared library
>>> '/Volumes/CoreData/CRAN/xps.Rcheck/xps/libs/i386/xps.so':
>>>  dlopen(/Volumes/CoreData/CRAN/xps.Rcheck/xps/libs/i386/xps.so, 6): no
>>> suitable image found.  Did find:
>>>        /Volumes/CoreData/CRAN/xps.Rcheck/xps/libs/i386/xps.so: mach-o,
>>> but wrong architecture
>>> ERROR: loading failed
>>> * removing '/Volumes/CoreData/CRAN/xps.Rcheck/xps'
>>> Do you have any hint what might be the reason for this error?
>> Apparently the R and your package have different architectures. The reason
>> is most likely your package - often badly written Makevars or Makefile if
>> some dependencies are used, or stale object files in the sources (failure to
>> clean up) etc. You'd have to show us the package and exactly how you're
>> trying to instal it if we are to help you further.
>>> As far as I understand this message means that Snow Leopard is the wrong
>>> architecture, why?
>> You understand the message incorrectly - it tells you the R (which is the
>> one loading the package) cannot find binary of the same architecture in the
>> package, but it can find another, different, architecture instead. "Snow
>> Leopard" is not an architecture it's an operating system.
>> Cheers,
>> Simon
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list