[R-SIG-Mac] Problems with read.xls on Mac OS X 10.6.3

Erich Studerus erich.studerus at bli.uzh.ch
Thu Apr 22 17:43:05 CEST 2010


I'm trying to read an Excel-File with the read.xls function from gdata 
(Version 2.7.1) on Mac with OS X 10.6.3, but get the following error 
Can't load 
for module Compress::Raw::Zlib: 
no appropriate 64-bit architecture (see "man perl" for running in 32-bit 
mode) at 
/System/Library/Perl/5.10.0/darwin-thread-multi-2level/DynaLoader.pm line 
  at /Users/.../Library/R/2.10/library/gdata/perl/Archive/Zip.pm line 12
Compilation failed in require at 
/Users/.../Library/R/2.10/library/gdata/perl/Archive/Zip.pm line 12.

I did not have this problem on a Mac with OX X 10.5.8. It seems that perl 
must be running in 32bit mode, but is running in 64bit mode by default on my 
system. The same problem has been discussed on R mailing list, but nobody 
has provided a solution as far as I can see:

I tried to change the default perl to version 5.8 by following the 
instructions under "man perl" but still get the same error message. Can 
anybody help me out?


More information about the R-SIG-Mac mailing list