[R-SIG-Mac] R hangs when loading packages

Smiler80 smiler80 at gmail.com
Thu May 21 13:57:42 CEST 2009


I've recently installed R (version 2.9.0) on my Mac OS (Leopard). I'm  
using the Mac R.app application. Upon start up this works fine,  
however if I try to load several packages the application simply hangs  
(even after leaving it alone for an hour).

Strangely, some applications work fine, others don't. Some examples of  
failures are: R commander, relimp, tcltk. Ultimately, I'm trying to  
get FactoMineR to work with R commander, but when trying to install  
the FactoMineR GUI, which I believe depends on R commander, it also  
hangs. (Note: loading the package FactoMineR itself works fine!)

I've tried to load the packages via the Package Manager, and via the  
command library(rcmdr). I've also tried re-installing the packages,  
and re-installing R entirely. I keep having the same problem.

Any help or suggestions would be greatly appreciated!


More information about the R-SIG-Mac mailing list