[R-SIG-Mac] [Rd] crash after using graphics in Rcmdr (PR#13679)

Rob Goedman robjgoedman at me.com
Sun May 3 00:46:44 CEST 2009

Hi John,

Thanks for your procedure to reliably 'crash' R.app.

On my system sometimes this leads to an immediate crash, sometimes it  
happens when I ask for a 2nd plot or use another application after  
closing the 1st graphics window. I think using Rcmdr creates a similar  
condition as sourcing a file with graphics commands from TextMate.

As a workaround, in all cases, if I go back to the R Console window  
and e.g. enter a CR that condition is 'cleared', closing the graphics  
window will no longer create an issue.

I've several times tried to track this problem down but never with any  
luck. I take it as another artifact of the way documents are created/ 
deleted in the current R.app.


On May 1, 2009, at 9:16 AM, John Fox wrote:

> Dear Rob,
> Thanks for picking this up. Please see my remarks below:
> On Fri, 01 May 2009 07:55:46 -0700
> Rob Goedman <goedman at mac.com> wrote:
>> John,
>> To the best of my knowledge this problem in R.app has been around at
>> least since the R-2.8 days, but likely much longer. I never use R
>> from  a Terminal, so don't know if it occurs or not outside R.app.
> I figured that the Rcmdr wasn't directly implicated, but my guess was
> that it was a tcltk issue, so this is very useful information. The
> problem didn't occur for me outside of R.app, but then I wasn't using
> the Quartz graphics device.
>> It's not related to Rcmdr and you're observation is indeed one of the
>> better ways to kind of reproduce the issue. Not sure if it always
>> does  though. If you have a 'hard' way of crashing R.app, please let
>> me know  the sequence. In cases when no output is written to the
>> console of  R.app I tend to make sure I enter an empty line before
>> closing the  graphics window.
> This "works" for me every time: (1) In a fresh R.app session, load the
> Rcmdr, library(Rcmdr). (2) "Data -> Data in packages -> Read data set
> from an attached package." Pick any data set. I used Prestige from the
> car package. (3) Draw any graph on the Quartz device. I used "Graphs  
> ->
> Histogram" and selected education. Close the Quartz device, and watch
> the crash.
> I hope that this proves of some use in diagnosing the problem.
>> This issue and sometimes very long sequences of plots (never have
>> been  able to make that reproducible, sometimes the crash happens up
>> to a  minute after R finishes a series of plots and I'm working in an
>> external editor like TextMate) are hard to pin down.
>> Regards,
>> Rob
>> Note: Hope you don't mind I've removed the R-bugs & R-devel Cc's.
> No -- this is more natural on r-sig-mac.
> Thanks for your help,
> John
>> On Apr 30, 2009, at 6:29 AM, John Fox wrote:
>>> Dear Neil,
>>> I had R 2.8.0 installed on my Mac Book, also with OS X 10.5.6, and
>> was
>>> unable to duplicate this problem. I then installed R 2.9.0 and
>>> observed the
>>> same problem that you did. In both cases, I used the latest version
>>> of the
>>> Rcmdr package, 1.4-10.
>>> I also observed the following: (1) The problem occurred only if I
>>> closed the
>>> Quartz graphics device after the first graph was plotted; if I
>> plotted
>>> another graph and then closed the device, the problem did not
>> occur.
>>> (2) The
>>> problem did not occur if I ran R from a terminal with an X11
>>> graphics device
>>> rather than using R.app.
>>> I'm afraid that there's not much more that I can do at this point,
>>> since my
>>> familiarity with Macs is minimal. I'm copying this message to Rob
>>> Goedman,
>>> who has proven helpful in the past. Of course, if there's something
>>> in the
>>> Rcmdr that's causing the problem and I can fix it, I will.
>>> Regards,
>>> John
>>>> -----Original Message-----
>>>> From: r-devel-bounces at r-project.org
>> [mailto:r-devel-bounces at r-project.org
>>>> ]
>>> On
>>>> Behalf Of nhepburn at ualberta.ca
>>>> Sent: April-28-09 1:25 PM
>>>> To: r-devel at stat.math.ethz.ch
>>>> Cc: R-bugs at r-project.org
>>>> Subject: [Rd] crash after using graphics in Rcmdr (PR#13679)
>>>> Full_Name: Neil Hepburn
>>>> Version: 2.81 and 2.90
>>>> OS: OS-X 10.5.6
>>>> Submission from: (NULL) (
>>>> When I create graphs using Rcmdr and then close the quartz
>> display, R
>>> blows
>>>> up
>>>> and tells me of a segmentation fault. It then gives me
>>>> *** caught segfault ***
>>>> address 0xc0000023, cause 'memory not mapped'
>>>> Possible actions:
>>>> 1: abort (with core dump, if enabled)
>>>> 2: normal R exit
>>>> 3: exit R without saving workspace
>>>> 4: exit R saving workspace
>>>> Selection:
>>>> This only happens if I create the graphics from within Rcmdr. If I
>>>> create
>>> the
>>>> graphics manually, there is no problem. This occurs on my laptop
>>>> with R
>>> 2.8.1
>>>> (I
>>>> uninstalled 2.9 and reinstall 2.8.1 to see if the problem existed
>>>> there)
>>> and
>>>> also on my iMac with R2.9.
>>>> ______________________________________________
>>>> R-devel at r-project.org mailing list
>>>> https://stat.ethz.ch/mailman/listinfo/r-devel
> --------------------------------
> John Fox, Professor
> Department of Sociology
> McMaster University
> Hamilton, Ontario, Canada
> http://socserv.mcmaster.ca/jfox/

More information about the R-SIG-Mac mailing list