[R-SIG-Mac] Error loading packages, command 'tar' missing from path?

Andrew J. Rominger rominger at stanford.edu
Tue Mar 3 23:52:13 CET 2009

Hello all,

My appologies for any possible cross-posting--I originally posted a version of this to R-Help, but was refered to r-sig-mac because apparently my problem is mac-specific.

I'm running R2.8.1 on a Mac OS 10.4.11.  While trying to install the package gdata, I was presented with the following (error at end of report):

> install.packages("gdata")
also installing the dependency ‘gtools’

trying URL 'http://cran.stat.ucla.edu/bin/macosx/universal/contrib/2.8/gtools_2.5.0-1.tgz'
Content type 'application/x-tar' length 85484 bytes (83 Kb)
opened URL
downloaded 83 Kb

trying URL 'http://cran.stat.ucla.edu/bin/macosx/universal/contrib/2.8/gdata_2.4.2.tgz'
Content type 'application/x-tar' length 539301 bytes (526 Kb)
opened URL
downloaded 526 Kb

/bin/sh: line 1: tar: command not found
2009-03-02 20:42:06.081 R[357] tossing reply message sequence 3 on thread 0x1ce3ae0
Error in sprintf(gettext(fmt, domain = domain), ...) :
  argument is missing, with no default

It seems that 'tar' is missing which (I'm guessing) leads to an error in sprintf().  I've never been presented with this error before.  I tried loading various other packages and received the same error.  When the error first appeared, I was running R2.5.3.  After upgrading to R2.8.1 the error persists.

Thanks in advance for any help--
Andy Rominger

More information about the R-SIG-Mac mailing list