[R-SIG-Mac] 64-bit build from source ... 64bit readline oddity solved; libiconv now

Vincent Carey stvjc at channing.harvard.edu
Sat Jul 25 12:39:28 CEST 2009

The solution to the readline problem was to remove all conflicting
libreadline.* on
the system.  However, now similar problems are cropping up with libiconv

you should 'make docs' now ...
building/updating package metadata ...
dyld: lazy symbol binding failed: Symbol not found: _libiconv_open
  Referenced from: /Users/stvjc/ExternalSoft/R-devel/lib/x86_64/libR.dylib
  Expected in: dynamic lookup

installing a fresh 32/64-bit libiconv and removing all conflicting
versions has not helped.

On Fri, Jul 24, 2009 at 3:54 PM, Vincent
Carey<stvjc at channing.harvard.edu> wrote:
> this build from a very recent svn checkout of devel is incomplete.  it fails
> while trying to build base with the same error as occurs here
> bash-3.2$ bin/R
> dyld: Symbol not found: _rl_basic_word_break_characters
>  Referenced from: /Users/stvjc/ExternalSoft/R-devel/lib/x86_64/libR.dylib
>  Expected in: dynamic lookup
> Trace/BPT trap
> i built readline 6.0 from source with the -arch x86_64 switch on gcc
> and configure
> worked ok.  i think the symbol exists
> nm /usr/local/lib/libreadline.6.0.dylib | grep break
> 000000000002b500 D _rl_basic_word_break_characters
> 000000000002b4f0 D _rl_completer_word_break_characters
> 000000000002b4e8 D _rl_completion_word_break_hook
> help!  the past few days have been nothing but glitches and bugs...
> --
> Vincent Carey, PhD
> Biostatistics, Channing Lab
> 617 525 2265

Vincent Carey, PhD
Biostatistics, Channing Lab
617 525 2265

More information about the R-SIG-Mac mailing list