[R-SIG-Mac] Package installation: setting default library

Carl Witthoft carl at witthoft.com
Mon Jan 5 23:33:02 CET 2009

Honest, I tried to find notes in the archives on this one.  Maybe I used 
the wrong keywords.

With sys 10.4.11, Intel iMac, I installed R 2.8.1 directly from the dmg 
installer package.

After that, I tried to install some R packages.  Due to port blocking at 
work, I have to download the files, unpack, and install from my local 

Using the R.app GUI, I selected "Install at System Level" and get an 
error message something like

" 'lib' variable not found, using default {my local Library/Frameworks 

The default value of libPaths was

[1] "/Users/carl/Library/R/2.8/library"
[2] "/Library/Frameworks/R.framework/Versions/2.8/Resources/library"

If I ran the command

R> .libPaths(.libPaths()[2])

{thus removing the reference to my local tree}

then the GUI properly installed to the system library tree.

So, is there a better, or simpler, way to make this happen?


More information about the R-SIG-Mac mailing list