[R-SIG-Mac] Error exec program in 64 bit R from terminal

Matthew Pittinsky mpittins at asu.edu
Fri Dec 18 20:55:44 CET 2009


My apologies in advance if this has been asked and answered, but I can't seem to find the information I need.

I am trying to run an R program from the terminal.  As a trivial example, I run  R --arch=x86_64 CMD BATCH /Users/mpittinsky/Desktop/test.r /Users/mpittinsky/Desktop/testoutput.txt, where the test.r program is the loading of a library (just to debug).  The library in question loads when I run the command from R64 console.  (The "real" program involves a  set of data cleaning and analysis functions).

I receive the errors:

/Library/Frameworks/R.framework/Resources/bin/R: line 231: /Library/Frameworks/R.framework/Resources/bin/exec/x86_64/R: No such file or directory
/Library/Frameworks/R.framework/Resources/bin/R: line 231: exec: /Library/Frameworks/R.framework/Resources/bin/exec/x86_64/R: cannot execute: No such file or directory

These directories do not, indeed, exist.  Only an i386 directory does and the above program works fine when the arch specified is i386. 

I installed R using the latest version at http://cran.r-project.org/bin/macosx/, so I am on 2.10.0.  I am running Mac OS 10.6.2.  

Thanks in advance for any suggestions.

Matthew Pittinsky, Ph.D.
Assistant Professor
Arizona State University 
School of Social and Family Dynamics, Program in Sociology
office: Social Sciences 217
phone: 480-727-9163
email: mpittinsky at asu.edu
web: www.public.asu.edu/~mpittins

More information about the R-SIG-Mac mailing list