[R-SIG-Mac] upgradeable R layout

David Winsemius dwinsemius at comcast.net
Fri Nov 14 17:30:27 CET 2008

Thanks, Steve.

You are perfectly within rights to question how comfortable I am using  
the Unix command line. I started on CP/M and PC-DOS and twenty yaers  
ago did my stats homework and thesis work on a VAX but have not really  
used CLI Unix to the point where I am comfortable with it.  I had  
gotten to the point where I thought I needed to ask a question. You  
are also correct that I was using cd rather than cp to navigate the  
directory tree.  I suspected that there was a flag or switch for the  
cp command and you offered one.  Your sudo tar <....> solution appears  
to have worked as hoped. Thank you very much.

David Winsemius

On Nov 14, 2008, at 11:09 AM, Steve Lianoglou wrote:

> Hi David,
>> The installation of the Tools is the sticking point:
>> I am attemptng to follow the directions at http://r.research.att.com/tools/
>> Checked Xcode and finding that it was 3.0 and seeing that 3.1.1 was  
>> available, download and installed  a 1GB file. Checked to see that  
>> Xcode.app had been updated.
>> Downloaded and installed the gfortran package from the ATT website.
>> copied "export PATH=$PATH:/usr/local/bin" to Terminal line.
>> Followed "Tools on CRAN" link:
>> devpack4-darwin8-bin4.tar.gz was download via Firefox to /Users/ 
>> Downloads/ and automatically expanded to a folder with Library and  
>> usr descendants within /Downloads/ which I think is not the correct  
>> location. The contents of Library were apparently destined for / 
>> Applications/Frameworks/R.framework/Resources/ so I dragged the  
>> fontconfig file there.
> That looks wrong to me. After having d/l'd the devpack to see what  
> was going on, it looks like the archive is destined to be expanded  
> at the root level of your system, meaning the Library folder in  
> there should really expand into:
> /Library/Frameworks/R.framework ...
> Same goes for the usr/local/blah/blah stuffs: this should be in /usr/ 
> local/blah/blah.
> I'm not sure if there's any undoing that needs to be done on your  
> side (doesn't seem so(?)). So, assuming we're starting from scratch:  
> in order to properly install the devpack that is d/l'd in your  
> downloads folder, you can type this in the terminal and all files  
> will expand into their correct place:
> $ sudo tar fvxz /Users/davidwinsemius/Downloads/devpack4-darwin8- 
> bin4.tar.gz -C /
>> Viewing the world through the Mac Finder it is unclear where the / 
>> usr/local folder contents are supposed to go.
> You can't see that folder, by default, via the Finder as its hidden.  
> You can force the Finder to open it in a window a few different  
> ways, though. One way is to open a new finder window, hit Cmd-Shift- 
> G to drop down the "Go to folder" dialog (Also available via the Go  
> menu), and then type /usr/local.
> Another way would be to fire up Terminal.app and type:
> $ open /usr/local
>> There is probably a Unix command that will safely copy the contents  
>> of the /usr/ folder currently residing in /Downlaods to where the  
>> "true" /usr/ folder resides. So I opened a Terminal window and typed:
>> cp  /usr/local/
> This isn't really a valid command, as cp takes two arguments. Maybe  
> you meant `cd`?
>> Can I now just type:
>> cp /Users/davidwinsemius/Downloads/devpack4-darwin8-bin4/usr/local/ 
>> * .
> If you meant `cd` above, this command wouldn't successfully copy all  
> of the stuff over to your directory, since you'll need the -R  
> command to copy the directories over  ...
> So, to re-iterate, all you have to do to get the devpack items  
> installed in the right place is to fire off the `tar xvfz ... `  
> command I listed above, don't do any more cp'ing or whatever else  
> you tried after that.
> Honestly, though, I'm tempted to provide a word of caution since it  
> seems you might not be very comfortable using the command line  
> (sorry if I'm making an incorrect assumption). You'll have to use  
> `sudo` to get this to work, and may unintentionally blow out  
> something in the process that could your system (the command I gave  
> you is safe, tho (I just ran it on my system and I'm doing OK :-)).
> Anyway, hope this helps.
> -steve
> --
> Steve Lianoglou
> Graduate Student: Physiology, Biophysics and Systems Biology
> Weill Medical College of Cornell University
> http://cbio.mskcc.org/~lianos

More information about the R-SIG-Mac mailing list