[R-SIG-Mac] rimage doesn't install on Mac OS X 10.4

Waichler, Scott R Scott.Waichler at pnl.gov
Thu Nov 13 08:09:04 CET 2008


> However, installation from the source tarball worked (Mac OS X 10.5,
> fftw2 headers from www.fftw.org in /usr/local/include, and 
> jpeglib from an earlier Macports install). R CMD install 
> rimage worked with the following sequence
> tar xvzf rimage_0.5-7.tar.gz
> cd rimage
> ./configure --with-fftw-include=/usr/local/include 
> --with-jpeg- include=/opt/local/include R CMD install rimage

Thanks for the suggestion.  I wasn't able to execute your last command
exactly as is, but after some trial-and-error, I got this to run as far
as it did.  Now there is a complaint about -ljpeg.  I copied libjpeg.a
to the working directory, and of course it is in many other places.  Any
more suggestions?

ice.pnl.gov:/home/waichler/rpm/ice/rimage<972>R CMD install --no-lock
--configure-args=--with-jpeg-include=/opt/local/include ../rimage
* Installing to library '/home/waichler/Library/R/2.8/library'
* Installing *source* package 'rimage' ...
checking for g++... g++
checking for C++ compiler default output... a.out
checking whether the C++ compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking for gcc... gcc
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking for egrep... grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking fftw.h usability... yes
checking fftw.h presence... yes
checking for fftw.h... yes
checking /opt/local/include/jpeglib.h usability... yes
checking /opt/local/include/jpeglib.h presence... yes
checking for /opt/local/include/jpeglib.h... yes
checking for inline... inline
checking for stdlib.h... (cached) yes
checking for GNU libc compatible malloc... no
configure: creating ./config.status
config.status: creating src/Makevars
** libs
** arch - ppc
g++ -arch ppc -dynamiclib -Wl,-headerpad_max_install_names
-mmacosx-version-min=10.4 -undefined dynamic_lookup -single_module
-multiply_defined suppress -L/usr/local/lib -o rimage.so equalize.o
fftw_access_func.o freqfilters.o interface.o jpegio.o laplacian.o
matrix.o smooth.o sobel.o -ljpeg -lfftw
-F/Library/Frameworks/R.framework/.. -framework R -Wl,-framework
/usr/bin/libtool: can't locate file for: -ljpeg
/usr/bin/libtool: file: -ljpeg is not an object file (not allowed in a
make: *** [rimage.so] Error 1
No such file or directory
ERROR: compilation failed for package 'rimage'
** Removing '/tmp_mnt/snow/files0/waichler/Library/R/2.8/library/rimage'


More information about the R-SIG-Mac mailing list