[R-SIG-Mac] rimage doesn't install on Mac OS X 10.4

Waichler, Scott R Scott.Waichler at pnl.gov
Wed Nov 12 18:45:45 CET 2008


I'm trying to install rimage on a Mac OS X 10.4 machine.  I followed the
advice in previous R-help threads and got over the hurdles of having the
header files in the right places, among other things.  But I can't
figure out what to do with this error.

ice.pnl.gov:/home/waichler<949>system_profiler -detailLevel mini
Software: System Software Overview:
      System Version: Mac OS X 10.4.11 (8S165)
      Kernel Version: Darwin 8.10.0
ice.pnl.gov:/home/waichler<942>echo $C_INCLUDE_PATH
ice.pnl.gov:/home/waichler<946>echo $MACOSX_DEPLOYMENT_TARGET

ice.pnl.gov:/home/waichler<947>sudo R CMD INSTALL
--configure-vars='LDFLAGS=-L/sw/lib CPPFLAGS=-I/sw/include'
. . . 
gcc -arch ppc -std=gnu99
-I/Library/Frameworks/R.framework/Resources/include/ppc -g -O2
-I/sw/include-I/usr/local/include    -fPIC  -g -O2 -c sobel.c -o sobel.o
g++ -arch ppc -dynamiclib -Wl,-headerpad_max_install_names
-mmacosx-version-min=10.4 -undefined dynamic_lookup -single_module
-multiply_defined suppress -L/usr/local/lib -o rimage.so equalize.o
fftw_access_func.o freqfilters.o interface.o jpegio.o laplacian.o
matrix.o smooth.o sobel.o -L/sw/lib -ljpeg -lfftw
-F/Library/Frameworks/R.framework/.. -framework R -Wl,-framework
ld: /Library/Frameworks/R.framework/../R.framework/R load command 14
unknown cmd field
/usr/bin/libtool: internal link edit command failed
make: *** [rimage.so] Error 1
bs/ppc/*: No such file or directory
ERROR: compilation failed for package 'rimage'

(I have also tried to install the package from the Mac GUI for R, but it
quits at not being able to find the jpeglib.h file, which I solved in
the command line session excerpted above using "setenv C_INCLUDE_PATH

Scott Waichler
Pacific Northwest National Laboratory
scott.waichler at pnl.gov

More information about the R-SIG-Mac mailing list