[R-SIG-Mac] Building packages under R >= 2.7.0 (issue with gcc-4.2)

Vincent Goulet vincent.goulet at act.ulaval.ca
Sun Jun 1 07:50:10 CEST 2008

My package checked and buit fine under 2.6.2 on Leopard 10.5.2. Under  
2.7.0, 2.7.0 patched (2008-05-29) and R-devel (2008-05-30) it always  
fails at the "checking whether package 'actuar' can be installed"   
step. The 00install.log tells me that R tried to call gcc-4.2, which I  
don't have. It is my understanding from reading the documentation that  
this version of gcc is not mandatory. I have XCode v. 3.0 installed.

Furthermore, I noticed that, for 2.7.0, the /Library/Frameworks/ 
R.framework/Resources/etc/*/Makeconf files refer to gcc for i386 and  
ppc, and to gcc-4.2 on x86_64. For 2.7.0 patched and R-devel, the  
Makeconf files refer to gcc-4.2 on all architectures.

I can't see what I did wrong, but then I'm certainly not the first one  
to compile a package from source since the release of 2.7.0. Any help  
would be appreciated.

Thanks in advance!

   Vincent Goulet, Associate Professor
   École d'actuariat
   Université Laval, Québec
   Vincent.Goulet at act.ulaval.ca   http://vgoulet.act.ulaval.ca

More information about the R-SIG-Mac mailing list