[R-SIG-Mac] Weird problems in Leopard

Simon Urbanek simon.urbanek at r-project.org
Thu Jul 17 16:35:34 CEST 2008

On Jul 16, 2008, at 4:55 PM, Duncan Murdoch wrote:

> I've just bought a new iMac with 10.5.4 of OS X.  I installed R  
> 2.7.1 on it with no problems.
> I tried to install Xcode 3.0, but three downloads (two Firefox, one  
> Safari) were corrupt, so I installed 3.1.
> Now, the weirdness:
> When I try to install rgl from the CRAN source,  or from a local  
> directory using R CMD INSTALL, the configure script fails with these  
> messages:
> checking for X... libraries /usr/X11/lib, headers /usr/X11/include
> checking for glEnd in -lGL... no
> configure: error: missing required library GL
> ERROR: configuration failed for package 'rgl'
> ** Removing '/Library/Frameworks/R.framework/Resources/library/rgl'
> ** Restoring previous '/Library/Frameworks/R.framework/Resources/ 
> library/rgl'
> However, if I run the configure script (as ./configure) within the  
> local directory, it succeeds:
> checking for X... libraries /usr/X11/lib, headers /usr/X11/include
> checking for glEnd in -lGL... yes
> I can then move the configure script out of the way and R CMD  
> INSTALL proceeds (until it gets to the FTVectoriser error, which I'm  
> working on fixing).
> Why would R CMD INSTALL make the configure script fail???

Hard to tell unless you look at config.log... Anyway, unless you work  
around the bug in Leopard's X11 in your configure you have fix to X11,  
GL is broken:


Also if you want to use X11 on Leopard seriously, it is recommended to  
use this update:



More information about the R-SIG-Mac mailing list