[R-SIG-Mac] /bin/sh: tar: command not found

Ben Bolker bolker at zoology.ufl.edu
Tue Aug 12 23:57:59 CEST 2008

   This is my package, but I don't think there's anything wrong with
the package (the check summary on CRAN says it's OK).  Does this happen
with all packages?  Have you tried a different mirror? (123 K seems
like a reasonable size for this package).

   On the other hand, the specific error message says the problem
is that R can't find the "tar" command -- is it in your path?

   Ben Bolker (not a Mac person)

Andrew Noble wrote:
> Today, I downloaded the most recent binary for R.app.  I'm running on 
> MacOSX 10.4.11.
> Downloading packages fail.  I've tried it at the command line and using 
> the "Packages & Data" menu.  In both cases, trying to downloaded the 
> "emdbook" binary, I get the following error.
> -----
> Warning in install.packages("emdbook") :
>   argument 'lib' is missing: using 
> '/Users/andrewnoble/Library/R/2.7/library'
> trying URL 
> 'http://cran.mirrors.hoobly.com/bin/macosx/universal/contrib/2.7/emdbook_1.1.1.tgz' 
> Content type 'application/x-tgz' length 126320 bytes (123 Kb)
> opened URL
> ==================================================
> downloaded 123 Kb
> /bin/sh: line 1: tar: command not found
> Error in sprintf(gettext(fmt, domain = domain), ...) :
>   argument is missing, with no default---
> -----
> Any help would be greatly appreciated.  Thank you!
> Andrew
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 252 bytes
Desc: OpenPGP digital signature
URL: <https://stat.ethz.ch/pipermail/r-sig-mac/attachments/20080812/82f6ab9d/attachment.bin>

More information about the R-SIG-Mac mailing list