[R-SIG-Mac] Error while running R CMD check

Kjell Konis kjell.konis at epfl.ch
Wed Apr 2 11:25:00 CEST 2008

After a little digging around...

It turns out that perl is responsible for this error. Although it is  
not mentioned in './configure --help', it appears that if the PERL  
environment variable is set then its value is put in R_HOME/etc/ 
Renviron during configure. This must have been the case for me as R  
somehow picked up a single threaded perl build that is not in my path.


On 1 avr. 08, at 20:09, Simon Urbanek wrote:
> Kjell,
> can you, please, send us the details (in accordance to the posting
> guide)?
> On Apr 1, 2008, at 12:46 PM, Kjell Konis wrote:
>> I built R from source and when I run R CMD check it prints the
>> following error while checking R code for possible problems.
>> ...
>> * checking R code for possible problems ... NOTE
>> The process has forked and you cannot use this CoreFoundation
>> functionality safely. You MUST exec().
>> Break on
>> () to debug.
>> <snip - same 2 lines a whole bunch of times>
>> * checking Rd files ... OK
>> ...
>> The package passes R CMD check on linux. Any ideas on how I can fix
>> it?
> Where do you get into those problems? The above error occurs on
> Leopard when a "fork"ed applications attempts to use CF calls.
> However, It's not clear to me 1) how you get a forked R and 2) how you
> get to call libraries using CF.
> So far I encountered this problem only in the setup Rserve+Cairo,
> because Rserve forks R to allow multiple connections. This can be
> worked around by using more recent freetype with cairo (old FT used
> FSRef API unnecessarily which in turn calls CF). Nonetheless, if your
> package relies on both forking and CF, you have no way out - it will
> be unsupported on Mac OS X 10.5.
> Cheers,
> Simon
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list