[R-SIG-Mac] YA Mac 64 bit Question

Karl Goiser karl.goiser at anu.edu.au
Sun May 6 09:31:37 CEST 2007


I am trying to get a 64 version of R running on my Mac Pro (like  
several others, it seems).  It seems there are two options, 10.4 and  

http://r.research.att.com/exp/ says to install Xcode [tick] and GNU  
Fortran [tick], get the R source (from CRAN, I assume, e.g. http:// 
cran.au.r-project.org/src/base/R-2/R-2.5.0.tar.gz) [tick], and  
configure with a suggested command line:

./configure CC='gcc -arch x86_64' CXX='g++ -arch x86_64'  
F77='gfortran -arch x86_64' FC='gfortran -arch x86_64' --with-blas='- 
framework vecLib' --with-lapack --without-x --with-system-zlib -- 
build=x86_64-apple-darwin8.8.1 --without-readline


When I run it (without r_arch=x86_64) I get an error:
configure: error: --with-iconv=yes (default) and suitable iconv is  
not available

What is this and how do I address it?

When I run the same configure as per the web site, I get a different  

./configure: line 61328: test: =: unary operator expected

If I then go on to 'make', I get the following:
ld64: warning: option -headerpad_max_install_names is obsolete and  
being ignored
ld64-72 failed: duplicate symbol _Rf_mkChar in CommandLineArgs.o and  

So, no luck with either version of the OS.

Could somebody assist me with these problems?  I am sorry in that I  
am not knowledgeable with all this installation of packages and the  

Thanks in advance,


More information about the R-SIG-Mac mailing list