[R-SIG-Mac] EBImage package from bioconductor

Sean Wiltshire sean.wiltshire at gmail.com
Thu Sep 28 18:59:01 CEST 2006

Hi all,
I've been having some problems getting the bioconductor library  
'EBImage' installed and running properly. It depends on imagemagick  
and I think I have that installed properly, I used fink  imagemagick- 
dev    6.1.8-3 without any obvious problems. I run 10.4.7, and I was  
using xcode 2.0 with R version 2.4.0 beta (2006-09-24 r39502),  

This is the package:

Here is what happens when I try to install:

root# R CMD install /Users/swilts/Desktop/EBImage_1.3.105.tar.gz*  
Installing *source* package 'EBImage' ...

/usr/bin/libtool: unknown option character `m' in: -macosx_version_min
Usage: /usr/bin/libtool -static [-] file [...] [-filelist listfile 
[,dirname]] [-arch_only arch] [-sacLT]
Usage: /usr/bin/libtool -dynamic [-] file [...] [-filelist listfile 
[,dirname]] [-arch_only arch] [-o output] [-install_name name] [- 
compatibility_version #] [-current_version #] [-seg1addr 0x#] [- 
segs_read_only_addr 0x#] [-segs_read_write_addr 0x#] [-seg_addr_table  
<filename>] [-seg_addr_table_filename <file_system_path>] [-all_load]  
make: *** [EBImage.so] Error 1
chmod: /Library/Frameworks/R.framework/Versions/2.4/Resources/library/ 
EBImage/libs/ppc/*: No such file or directory

So, I tried installing glibtool using fink, this didn't seem to fix  
anything, then I heard from a friend that maybe getting xcode 2.4  
would fix libtool, I signed up and downloaded that, tried again.
Now, the package seems to finish compiling but when I try to load it  
into R I get this:

 > library(EBImage)
Error in dyn.load(x, as.logical(local), as.logical(now)) :
         unable to load shared library '/Library/Frameworks/ 
libs/ppc/EBImage.so, 6): Symbol not found: __ZTIN6Magick9ExceptionE
   Referenced from: /Library/Frameworks/R.framework/Resources/library/ 
   Expected in: dynamic lookup
Error: package/namespace load failed for 'EBImage'

Has anyone else installed this package on a mac successfully? Any  
pointers even if you haven't? Is this still a problem with libtool  
not working properly? One friend suggested I replace libtool with  
glibtool, is that safe?


More information about the R-SIG-Mac mailing list