[R-SIG-Mac] problem with R prompt on MAC

Tom Cook cook at biostat.wisc.edu
Mon Mar 20 19:21:48 CET 2006

I have a MAC powerbook on which I have been running R, usually via an
X11-based version of emacs that I compiled myself.  I recently
upgraded my teTeX distribution, after which I began experiencing a
problem with R.  Specifically, the prompt has disappeared.  If I run R
in a shell window, I get no prompt, but if I imagine that one is there
and just type stuff as usual, it seems to function normally.  (Also
options()$prompt returns "> " as expected.)  If I run R via emacs, the
lack of a prompt confuses ESS, so that's a problem.  I'm assuming that
there is some library that I "upgraded" when I installed teTeX which R
is also using which is causing this problem, but I have no idea what
it could be.  Other interactive programs running within the shell
don't seem to have been affected.

I reinstalled the R MAC binaries thinking this might put something
back, but it didn't fix the problem.  Next, I downloaded the latest R
source and recompiled, but this didn't fix it either.  I also thought
it might have something to do with "readline" but running R with or
without "--no-readline" has no effect.

Does anyone have any idea what could be going on?  Is there anything
else I should try?  Is there a standard library that handles this
operation that I should look for? 

Any help would be appreciated.

More information about the R-SIG-Mac mailing list