[R-SIG-Mac] Error loading RMySQL (was: Error building R from source)

Georg Otto georg.otto at tuebingen.mpg.de
Wed Jan 25 12:24:28 CET 2006

Simon Urbanek <simon.urbanek at r-project.org> writes:

> On Jan 24, 2006, at 1:27 PM, Georg Otto wrote:
>> I tried to build R 2.2.1 from source on Mac OS 10.4.3 Tiger, Darwin  
>> 8.3.0
>> I was proceeding like this:
>> ./configure F77=g77 CC="/usr/bin/gcc-3.3"
>> make
> You will need to run
> sudo gcc_select 3.3
> before configuring R (and you don't need to set F77/CC if you don't  
> want to). If that doesn't help, please let me know.

Thanks a lot for your help, this worked fine!

Unfortunately I am running into another problem: I can not load RMySQL
after installing it from source. What I do is the following:

sudo gcc_select 3.3
export PKG_CPPFLAGS="-I/usr/local/mysql/include"
export PKG_LIBS="-L/usr/local/mysql/lib -lmysqlclient"

sudo R CMD INSTALL RMySQL_0.5-5.tar.gz 

This seems to work, but when I try to load RMySQL in R i get the
following error message:

> library(RMySQL)
Error in dyn.load(x, as.logical(local), as.logical(now)) : 
        unable to load shared library '/Library/Frameworks/R.framework/Resources/library/RMySQL/libs/RMySQL.so':
  dlopen(/Library/Frameworks/R.framework/Resources/library/RMySQL/libs/RMySQL.so, 6): Symbol not found: _printf$LDBLStub
  Referenced from: /Library/Frameworks/R.framework/Resources/library/RMySQL/libs/RMySQL.so
  Expected in: flat namespace
Error in library(RMySQL) : .First.lib failed for 'RMySQL'

Any idea how I could solve this?



More information about the R-SIG-Mac mailing list