[R-SIG-Mac] Rgraphviz failed to load in Mac OSX 10.4.5

Kasper Daniel Hansen khansen at stat.Berkeley.EDU
Tue Feb 28 21:46:55 CET 2006

Just before christmas I recompiled graphviz and Rgraphviz using gcc  
3.3 and Xcode 2.2. I had loads of problems with earlier versions of  
grapviz (which I seem to recall I had been able to get working). In  
fact I spend hours trying to get it to work. But the devel version  
compiled just fine (I think that was  graphviz-2.7.20051203.0540). I  
tried that out after finding an obscure post on an email list saying  
some MacOS issues had been fixed.

Obviously I have not tried with the newest devel version. And I am  
not sure I tried make check. But Rgraphviz compiled and I could get  
it to display graphs.


On Feb 28, 2006, at 8:37 AM, Simon Urbanek wrote:

> Bernard,
> I can confirm the problem and there is indeed an issue with the
> current binary package. I have updated to the latest graphviz and
> built a new binary, but then I get segfaults inside graphviz on make
> check (both 2.8 and 2.9), so I'll have to dig a bit deeper. I'll keep
> you updated.
> Cheers,
> Simon
> On Feb 27, 2006, at 10:07 PM, Bernard Leong wrote:
>> I have installed the latest version of R in my Mac OSX 10.4.5, and
>> installed the bioconductor packages. When I tried to load Rgraphviz,
>> it returns the following error.
>>> library(Rgraphviz)
>> Loading required package: graph
>> Loading required package: cluster
>> Loading required package: Ruuid
>> Error in dyn.load(x, as.logical(local), as.logical(now)) :
>> 	unable to load shared library
>> '/Library/Frameworks/R.framework/Resources/library/Rgraphviz/libs/
>> Rgraphviz.so':
>>   dlopen(/Library/Frameworks/R.framework/Resources/library/
>> Rgraphviz/libs/Rgraphviz.so,
>> 6): Symbol not found: _agedgeattr
>>   Referenced from:
>> /Library/Frameworks/R.framework/Resources/library/Rgraphviz/libs/
>> Rgraphviz.so
>>   Expected in: flat namespace
>> Error: .onLoad failed in 'loadNamespace' for 'Rgraphviz'
>> Error: package/namespace load failed for 'Rgraphviz'
>> I have also installed graphviz using Fink, and set the
>> $LD_LIBRARY_PATH to the graphviz directory. But it still failed.
>> Please let me know if there are other ways to get around this.
>> Best regards,
>> Bernard
>> _______________________________________________
>> R-SIG-Mac mailing list
>> R-SIG-Mac at stat.math.ethz.ch
>> https://stat.ethz.ch/mailman/listinfo/r-sig-mac
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

More information about the R-SIG-Mac mailing list