[R-SIG-Mac] [R] RMySQL Error Messages, crashing R

Simon Urbanek simon.urbanek at r-project.org
Mon Feb 20 15:41:53 CET 2006


please consult the R FAQ for Mac OS X, this has been discussed many  
times - run
sudo gcc_select 3.3

Just in case you are using Xcode 2.2.1, you may also want to read this:

As it says, last time I checked, I had no problem using the stock  
MySQL libraries (i.e. simply the binary from www.mysql.com), no need  
to re-compile it.


On Feb 20, 2006, at 8:35 AM, Jason Horn wrote:

> Phil,
> Thanks for the tip.  I have tried rebuilding the RMySQL library, but
> it always fails.  When I run:
> R CMD INSTALL --configure-args='--with-mysql-inc=/usr/local/mysql/
> include --with-mysql-lib=/usr/local/mysql/lib' /Users/jason/Desktop/
> RMySQL_0.5-7.tar.gz.tar
> I get ...
> gcc-3.3 -bundle -flat_namespace -undefined suppress -L/usr/local/lib -
> o RMySQL.so RS-DBI.o RS-MySQL.o -L/usr/local/mysql/lib -lmysqlclient -
> lz -lcc_dynamic -F/Library/Frameworks/R.framework/.. -framework R
> ld: can't locate file for: -lcc_dynamic
> make: *** [RMySQL.so] Error 1
> ERROR: compilation failed for package 'RMySQL'
> The MySQL that I have is 5.0.18 that I downloaded as a binary
> directly from mysql.com.  Is your mySQL installation from elsewhere?
> What do you mean "...that I installed through port."
> It sounds like you have everything working.  What commands did you
> use to get mySQL 5 installed?  To get  RMySQL compiled?  Any help
> here is appreciated. I am heavily dependent on R working with mySQL
> for my project.

More information about the R-SIG-Mac mailing list