[R-SIG-Mac] R 2.1.1 available in DarwinPorts

Kjell Konis konis at stats.ox.ac.uk
Thu Sep 8 00:45:20 CEST 2005

On 7 Sep 2005, at 15:00, Jim McLoughlin wrote:

> 1. I am up to date with darwin ports:

Okay, so much for the easy fix.

> shiney:~ jim$ port version
> Version: 1.012
>> I actually changed the Portfile so that when the host is running OS X
>> the Apple gcc-3.3 and g++-3.3 get used instead of the GNU compilers
>> that are installed by DarwinPorts.  For some reason on my computer -
>> lcc_dynamic is passed to gcc-3.3 when libR.dylib is created (see
>> below) but it looks like this is specific to me.  I am testing a
>> Portfile with -lcc_dynamic included in LDFLAGS and it looks like it
>> still works for me (but honestly why wouldn't it).  Hopefully it will
>> work for Elijah and Jim too.
> 2. I noticed that when I first did `sudo install port R` yesterday,  
> it built a version of gcc (gcc-dp-3.4), so it must not be using the  
> osx gcc 3.3 by default.  `port variants R` returns:
> darwin_6
> macosx
> so it might be that we need to run `sudo port install R +macosx` to  
> force usage of the built in gcc-3.3.  However, When I tried this, I  
> got the same error as in 3 below (for the non-variant port).

The only way to get g77 is to install all of gcc 3.4.4.  On OS X the  
macosx variant is used by default (which uses the gcc-3.3 and g++-3.3  
provided by Apple with the developer tools and the g77-dp-3.4.4  
provided by DarwinPorts).  The darwin_6 variant is there to support  

Can you send me the config.log.  Also what version of OS X do you  
have and do you have any software installed in /usr/local?


> 3. I tried adding -lcc_dynamic to the LDFLAGS, but it still did not  
> build.  It now fails with:
> --->  Fetching R
> --->  Attempting to fetch R-2.1.1.tar.gz from http://cran.r- 
> project.org/src/base/R-2/
> --->  Verifying checksum(s) for R
> --->  Extracting R
> --->  Configuring R
> Error: Target com.apple.configure returned: configure failure:  
> shell command "cd "/opt/local/var/db/dports/build/ 
> file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupd 
> ate_dports_math_R/work/R-2.1.1" && CPPFLAGS="-I/opt/local/include"  
> LDFLAGS="-L/opt/local/lib -lcc_dynamic" CC=gcc-dp-3.4 CXX=g++- 
> dp-3.4 F77=g77-dp-3.4 CC=gcc-3.3 CXX=g++-3.3 ./configure --prefix=/ 
> opt/local --with-tcl-config="/opt/local/lib/tclConfig.sh" --with-tk- 
> config="/opt/local/lib/tkConfig.sh" --disable-R-framework --enable- 
> R-shlib --with-blas="-framework vecLib" --with-lapack" returned  
> error 77
> Command output: checking for dvips... /opt/local/bin/dvips
> checking for tex... /opt/local/bin/tex
> checking for latex... /opt/local/bin/latex
> checking for makeindex... /opt/local/bin/makeindex
> checking for pdftex... /opt/local/bin/pdftex
> checking for pdflatex... /opt/local/bin/pdflatex
> checking for makeinfo... /opt/local/bin/makeinfo
> checking for unzip... /usr/bin/unzip
> checking for zip... /usr/bin/zip
> checking for gzip... /usr/bin/gzip
> checking for firefox... no
> checking for mozilla... no
> checking for netscape... no
> checking for galeon... no
> checking for kfmclient... no
> checking for opera... no
> checking for gnome-moz-remote... no
> checking for open... /usr/bin/open
> using default browser ... /usr/bin/open
> checking for acroread... no
> checking for acroread4... no
> checking for xpdf... no
> checking for gv... no
> checking for gnome-gv... no
> checking for ggv... no
> checking for kghostview... no
> checking for open... /usr/bin/open
> checking for gcc... gcc-3.3
> checking for C compiler default output file name... configure:  
> error: C compiler cannot create executables
> See `config.log' for more details.

More information about the R-SIG-Mac mailing list