[R-SIG-Mac] compile problem on OS 10.4, R-2.1.0

Byron Ellis ellis at stat.harvard.edu
Tue May 3 02:09:15 CEST 2005

He's gettin' 'em from the same place I am I'm guessing: the tarballs.  
It looks like blowing out my /usr/local and going back to the Panther  
g95 have solved all my problems for the time being. Its a shame Apple  
doesn't ship a modern libdb, but I'm guessing there's a licensing  
concern there.

On May 2, 2005, at 1:45 PM, Simon Urbanek wrote:

> On May 2, 2005, at 3:32 PM, George W. Gilchrist wrote:
>> I decided to have a go compiling R 2.1.0 with the new release of  
>> 10.4. Any idea what the problem might be with this? I don't think  
>> there is anything wrong with /usr/local/lib/libpng.dylib...
> There is - it conflicts with the system one (as the error message  
> unmistakably tells you). For details see my post in response to the  
> exactly same problem described by Bill - don't use unversioned png/ 
> jpeg/... libraries in /usr/local! I don't know where you get them  
> from, but they are bad. Use static libraries or correctly versioned  
> dynamic ones. The CRAN release has no such problem because the  
> libraries are properly versioned. The really clean solution is to  
> switch to ImageIO framework, but that's not quite trivial.
> Cheers,
> Simon
> _______________________________________________
> R-SIG-Mac mailing list
> R-SIG-Mac at stat.math.ethz.ch
> https://stat.ethz.ch/mailman/listinfo/r-sig-mac

Byron Ellis (ellis at stat.harvard.edu)
"Oook" -- The Librarian

More information about the R-SIG-Mac mailing list