[R-sig-hpc] Installing gputools fails on Ubuntu 14.04LTS

Erol Biceroglu erol.biceroglu at alumni.utoronto.ca
Wed Jul 1 22:31:15 CEST 2015


Thank you both for the help.

The short answer is it's still not working, with the same error message.
Here are the actions I took.

1) So in my /gputools folder I see a 'configure.ac' file.

I opened it in a text editor, and changed all the AC_HELP_STRING lines with
the appropriate paths (lines 6, 18, 42, 55, 64, respectively):


saved the file...

So then I ran
*autoconf configure.ac <http://configure.ac> > configure *
and then
*chmod +x configure*

I get a "configure" file in my /gputools folder.

I then ran the executable by typing:

and then got the following output:

*checking "CUDA compiler"... "environment variable NVCC not set"*
*checking for nvcc... /usr/local/cuda/bin/nvcc*
*"using NVCC=/usr/local/cuda/bin/nvcc"*
*checking "root of the CUDA install directory"... "environment variable
CUDA_HOME not set"*
*"using CUDA_HOME=/usr/local/cuda"*
*checking "location of CUDA libraries"... checking for
"/usr/local/cuda/lib/libcublas.so"... no*
*checking for "/usr/local/cuda/lib64/libcublas.so"... yes*
*checking "R"... "using /usr/lib/R for the root of the R install directory"*
*"using /usr/lib/R/include for R header files"*
*checking for rpath flag style... checking for cc... cc*
*checking whether the C compiler works... yes*
*checking for C compiler default output file name... a.out*
*checking for suffix of executables... *
*checking whether we are cross compiling... no*
*checking for suffix of object files... o*
*checking whether we are using the GNU C compiler... yes*
*checking whether cc accepts -g... yes*
*checking for cc option to accept ISO C89... none needed*
*rpath flag style... gnu*
*checking build system type... x86_64-unknown-linux-gnu*
*checking host system type... x86_64-unknown-linux-gnu*
*configure: creating ./config.status*
*config.status: creating src/Makefile*

so then, I go back to my home directory and run:
* R CMD INSTALL gputools_0.5.tar.gz*

and then I get:

* installing to library ‘/home/erol/R/library’
* installing *source* package ‘gputools’ ...
** libs
Warning: no source files found
** R
** preparing package for lazy loading
** help
*** installing help indices
** building package indices
** testing if installed package can be loaded
Error in library.dynam(lib, package, package.lib) :
  shared object ‘gputools.so’ not found
Error: loading failed
Execution halted
ERROR: loading failed
* removing ‘/home/erol/R/library/gputools’

My apologies if I've missed something or misinterpreted anything.

I do want to add that I re-ran *deviceQuery* and it passed, as well as
*bandwidthTest*, which also passed.  Let me know if the output of the two
tests would be helpful.

Thanks very much for your advice and help.


Erol Biceroglu

*erol.biceroglu at alumni.utoronto.ca <erol.biceroglu at alumni.utoronto.ca>*

On Wed, Jul 1, 2015 at 2:37 PM, Charles Determan <cdetermanjr at gmail.com>

> If you download directory from the github repo you aren't provided with a
> 'configure' file but the 'configure.ac' file (which is in the src/
> directory of your gputools directory).  As such none of compilation
> instructions, which are rather complex for CUDA, are being passed to your
> compiler which will create the gputools.so file you are looking for.  You
> first need use the 'autoconf' program to create the 'configure' file.
> autoconf configure.ac > configure
> # make executable
> chmod +x configure
> Then try it again, report back if you have further problems.
> Regards,
> Charles
> On Wed, Jul 1, 2015 at 12:25 PM, Erol Biceroglu <
> erol.biceroglu at alumni.utoronto.ca> wrote:
>> Hello,
>> I'm trying to install gputools on Ubuntu 14.04LTS and I'm not having much
>> luck.  I'm not sure if it helps, but here's the R info that's output when
>> I
>> run it:
>> R version 3.2.0 (2015-04-16) -- "Full of Ingredients"
>> Copyright (C) 2015 The R Foundation for Statistical Computing
>> Platform: x86_64-pc-linux-gnu (64-bit)
>> Here are the steps I've taken so far:
>> *1) Run the following in the terminal:*
>> *git clone https://github.com/nullsatz/gputools.git
>> <https://github.com/nullsatz/gputools.git>*
>> -This creates a "gputools" folder in my /home directory
>> *2)  Then run the following in the terminal:*
>> *R CMD build gputools*
>> -This creates the gputools_0.5.tar.gz in my home folder
>> *3) Then I run the following command (which is causing issues)*
>> *R CMD INSTALL --configure-args="--with-nvcc=/usr/local/cuda/bin/nvcc
>> --with-r-lib=/usr/lib/R/lib --with-r=/usr/lib/R/ " gputools_0.5.tar.gz*
>> and I get the following output:
>> ** installing to library ‘/home/erol/R/library’*
>> ** installing *source* package ‘gputools’ ...*
>> *** libs*
>> *Warning: no source files found*
>> *** R*
>> *** preparing package for lazy loading*
>> *** help*
>> **** installing help indices*
>> *** building package indices*
>> *** testing if installed package can be loaded*
>> *Error in library.dynam(lib, package, package.lib) : *
>> *  shared object ‘gputools.so’ not found*
>> *Error: loading failed*
>> *Execution halted*
>> *ERROR: loading failed*
>> ** removing ‘/home/erol/R/library/gputools’*
>> ** restoring previous ‘/home/erol/R/library/gputools’*
>> I've checked the paths, and found my '*libR.so*' tucked away all alone in
>> */usr/lib/R/lib*, but I don't know where *gputools.so* is and I can't find
>> it by searching.
>> Any feedback on how to proceed would be greatly appreciated.
>> Thanks for your help.
>> Regards,
>> Erol Biceroglu
>> *erol.biceroglu at alumni.utoronto.ca <erol.biceroglu at alumni.utoronto.ca>*
>>         [[alternative HTML version deleted]]
>> _______________________________________________
>> R-sig-hpc mailing list
>> R-sig-hpc at r-project.org
>> https://stat.ethz.ch/mailman/listinfo/r-sig-hpc

	[[alternative HTML version deleted]]

More information about the R-sig-hpc mailing list