[R-sig-hpc] Rmpi openMPI error

Bryan Loughry loughry at me.com
Wed Sep 7 19:11:26 CEST 2011


We have been using Rmpi and openMPI for a long time and recently upgraded to R 2.13.1, openMPI 1.4.1 (also tried 1.4.3), Rmpi 0.5-8

We are now getting the error shown below.  Have also tried to roll back to our previous versions but have been unable to get this to work.  It seems to be Rmpi as we have no issues with mpirun working (locally or across machines).  Below if a copy of my terminal session.  Notice that the first run works but the executing the exact same run again it fails?  Any suggestions/help would be much appreciated.

loughry at deduce:~$ orterun -np 9 -H deduce R CMD BATCH test.r
loughry at deduce:~$ orterun -np 9 -H deduce R CMD BATCH test.r
[deduce:20539] [[63403,0],0] ORTE_ERROR_LOG: Not found in file ../../../../../orte/mca/plm/base/plm_base_launch_support.c at line 758
orterun was unable to start the specified application as it encountered an error.
More information may be available above.

test.r is:

# Load the R MPI package if it is not already loaded. 
if (!is.loaded("mpi_initialize")) { 
library("Rmpi") } 
# Spawn as many slaves as possible 
# In case R exits unexpectedly, have it automatically clean up 
# resources taken up by Rmpi (slaves, memory, etc...) 
.Last <- function(){ 
if (is.loaded("mpi_initialize")){ 
if (mpi.comm.size(1) > 0){ 
print("Please use mpi.close.Rslaves() to close slaves.") 
mpi.close.Rslaves() } 
print("Please use mpi.quit() to quit R") 
.Call("mpi_finalize") } }
# Tell all slaves to return a message identifying themselves 
mpi.remote.exec(paste("I am",mpi.comm.rank(),"of",mpi.comm.size())) 
# Tell all slaves to close down, and exit the program 

Bryan Loughry
loughry at me.com

More information about the R-sig-hpc mailing list