[R-sig-hpc] doSMP warnings and crash on WinXP

Johnson, Cedrick W. cedrick at cedrickjohnson.com
Sun Jun 26 19:40:34 CEST 2011


When I first initialize a doSMP object (specifying two cores) as below, 
within RStudio (latest) it crashes the app. I brought up the regular R 
console (2.13.0) and tried to do the same thing but received some 
interesting warnings:

 > library(doSMP)
Loading required package: foreach
Loading required package: iterators
Loading required package: codetools
foreach: simple, scalable parallel programming from Revolution Analytics
Use Revolution R for scalability, fault tolerance and more.
Loading required package: revoIPC
 > tmp = startWorkers(2)
Warning messages:
1: In startWorkers(2) : there is an existing doSMP session using doSMP1
2: In startWorkers(2) : there is an existing doSMP session using doSMP2

Here's my dillemma. Where is said existing doSMP session? Could it be a 
"dirty" file leftover somewhere from a previous call that's causing this 
to 1) crash RStudio and 2) generate these warnings? A quick look at the 
processlist doesn't show anything running. I've even tried doing this 
after a clean reboot with the same error.


R version 2.13.0 (2011-04-13)
Platform: i386-pc-mingw32/i386 (32-bit)

[1] LC_COLLATE=English_United States.1252  LC_CTYPE=English_United 
[3] LC_MONETARY=English_United States.1252 LC_NUMERIC=C
[5] LC_TIME=English_United States.1252

attached base packages:
[1] stats     graphics  grDevices datasets  utils     methods   base

other attached packages:
[1] doSMP_1.0-1     revoIPC_1.0-3   foreach_1.3.2   codetools_0.2-8 
[6] rcom_2.2-3.1    rscproxy_1.3-1

loaded via a namespace (and not attached):
[1] tools_2.13.0

Thanks for any guidance.


More information about the R-sig-hpc mailing list