[R-sig-Geo] ENFA in Linx

alannie agg18 at pitt.edu
Fri Jun 28 19:35:26 CEST 2013

Hi R-Sig-Geo community!

I was recently trying to run ADEHabitat ecological niche factor analysis
(ENFA) using R in Linux. I did not get very far and would like some
assistance on how to make it work in the future.

I did the following commands: 

I installed both ade4 and ADEHabitat on to R in Linux

Imported 26 .asc maps into R using this general syntax:
bio2<-import.asc("ASCII Envi Variables//caorwa//bio2.asc")

I added location data:


added the libraries for ade4/adehaitat

I compiled the .asc maps into "maps" using: 


Then I tried to prepare the data for the ENFA:


After this step I received an error message:

Error in cut.default(x, xc) : 'x' must be numeric
Error: unexpected 'in' in "Error in"

I have done the exact same thing in just windows many times and have not
received an error like this. In fact, it worked perfectly until the end of
the enfa. I had to switch to Linux because Windows ran out of memory for the
large area based analyses.

What would be causing the error? 

Is there something that needs to be configured differently in Linux?

Please let me know your suggestions! 

Linux Specifications:

adehabitat version 1.8.12 on R version 2.15.3 (2013-03-01) running on 64-bit
Linux 12.04.2 

Thank you, Community!


View this message in context: http://r-sig-geo.2731867.n2.nabble.com/ENFA-in-Linx-tp7583942.html
Sent from the R-sig-geo mailing list archive at Nabble.com.

More information about the R-sig-Geo mailing list