[R-sig-Geo] rgdal: libgdal requirements too restrictive

Kirill Müller kirill.mueller at ivt.baug.ethz.ch
Sun Apr 21 15:22:36 CEST 2013

Dear Roger

On 04/15/2013 10:49 AM, Roger Bivand wrote:
> Please rather use R-sig-geo.
> GDAL 1.6.3 was published 25-Nov-2009; 1.10.1 will be published soon. 
> 1.6.3 is no longer supported or fit for service, I'm afraid. GEOS is 
> currently at 3.3.8, and 3.2.* are not supoorted or fit for service. 
This would mean, in turn, that Debian stable is not "fit for service". 
Can't I run GIS software on Debian at all, without installing stuff from 
source (which might break Debian's otherwise decent package management)?
> In both cases, numerous bugs have been corrected and additional 
> functionality has arrived.
And likewise, three years from now, the current version will look so 
much 2013.
> Your only choice is to install GDAL and GEOS from source, there is no 
> way that rgdal and rgeos developer(s) - me alone - can back-support 
> ancient dependencies. 
It's not about really supporting an ancient version. It's about making 
the R package installable at all under an operating system with, by 
default, rather old software packages. The only change that is required 
on the side of rgdal/rgeos is to lower the dependency. The package 
installs, the tests show no error. Are you aware of any rgdal/rgeos 
functionality which would be broken if run under an older GDAL/GEOS?

I understand that this might raise additional maintenance burden. Can't 
you just say "GEOS >= 3.3.8", or something like that, in the 
DESCRIPTION, and have the configure script print a warning but allow 
installation if 3.2.0 <= GEOS < 3.3.8? Same for rgdal. Anyone really 
coming up with a bug report for an older version could then be asked to 
test it in a current installation, say, in a virtual machine.

I'd like to ask you to reconsider your position. After all, I have 
"fixed" the problem for myself, and I can maintain the tweaked package 
sources for myself. It's just to make life easier for those who have to 
run GIS on Debian...
> In conclusion - install from source. Maybe also write to R-sig-deb, 
> but because this is external to thenm, they won't help. I think that 
> this is a Debian GIS FAQ.
I'd love to hear of any option, other than installing from source, to 
update my Debian to supported versions of the required libraries -- 
without having to update libc and the compiler as well. I have looked, 
but found nothing.

Thank you.



> On Sun, 14 Apr 2013, Kirill Müller wrote:
>> Dear Roger
>> Just like rgeos [1], I cannot install current rgdal on the "most 
>> recent" Debian stable. Switching to "testing" is not an option for us.
>> Debian squeeze comes with libgdal 1.6.3. I have changed the 
>> requirements in the configure script and installed the package on my 
>> system, all tests succeeded. I have attached the patch in case you 
>> want to reduce the requirements for the other Debian users around.
>> Cheers
>> Kirill
>> [1] https://github.com/rundel/rgeos/issues/1

More information about the R-sig-Geo mailing list