[R-sig-Geo] MACOSX: rgdal cannot find GDAL

Agustin Lobo alobolistas at gmail.com
Tue Dec 28 10:28:27 CET 2010


Setting the path as you indicate solves the problem of running gdalinfo:
imac-de-agustin-lobo:~ agustinlobo$ export
imac-de-agustin-lobo:~ agustinlobo$ echo
imac-de-agustin-lobo:~ agustinlobo$ gdalinfo --version
GDAL 1.7.3, released 2010/11/10

Therefore we can close this thread on installing GDAL and rgdal on
MACOSX from the kyngchaos server!
I'll be sending the link with directions for dummies shortly

Thank you all


2010/12/27 Ralf Schäfer <senator at ecotoxicology.de>:
> Hi Agustin,
>>> Can you allocate the folder:
>>> /Library/Frameworks/GDAL.framework ????
>> Yes:
>> imac-de-agustin-lobo:Frameworks agustinlobo$ pwd
>> /Library/Frameworks
>> This problem persists:
>> imac-de-agustin-lobo:GDAL.framework agustinlobo$ gdalinfo --version
>> -bash: gdalinfo: command not found
>> But actually, the R installation of rgdal works now. Could it be that
>> I needed to reboot after
>> installing GDAL? I'd like to clarify as I'm trying to write up directions:
> I am not a Shell expert - but my guess would be that the GDAL commands are not in your PATH. So when you type the commands Shell does not find them.
> Try to include them in your Path:
> export PATH=/Library/Frameworks/GDAL.framework/Programs:$PATH
> I actually think that I had to do this as well...
> In case that works you can write this path to your profile so you have it for every terminal session - here is a short guide:
> http://www.macgasm.net/2008/04/10/adding-a-new-location-to-your-path-variable-within-terminal/
>> The other one is the problem installing rgdal from CRAN repositories 1 and 2
> Unfortunately, I have no idea why this fails for you. In fact, I checked it as well, and did not work for me either. I get the same error even when I specify GDAL and Proj path:
> install.packages("rgdal", configure.args='--with-gdal-config=/Library/Frameworks/GDAL.Framework/unix/bin/gdal-config --with-proj-include=/Library/Frameworks/PROJ.framework/unix/include-with-proj-lib=/Library/Frameworks/PROJ.framework/unix/lib/')
> So that is why I also installed from source as outlined previously- and I noticed that on the CRAN source there is a later version of rgdal 0.6-33 instead of 0.6-31, may be this is the problem (I updated to R 2.12.1).
> I reckon other people can be of more help here.
>> I still do not know which one is to be preferred...
> Well, as Roger Bivand pointed out (24.12)  Installing from CRAN/CRAN extra is certainly the best option. May be there is a fix to install the binary from CRAN/CRAN extra
> Otherwise certainly the kyngchaos binaries are the most convenient way (yet they are rgdal 0.6-29)
> Cheers
> Ralf
>        [[alternative HTML version deleted]]
> _______________________________________________
> R-sig-Geo mailing list
> R-sig-Geo at r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-geo

More information about the R-sig-Geo mailing list