[R-sig-Geo] Error to load rgdal

Susumu Tanimura stanimura-ngs at umin.ac.jp
Thu May 12 03:59:23 CEST 2005

Hi, there

Failure of loading rgdal 0.2-7 gives me the following message.

> library(rgdal)
Loading required package: abind
Loading required package: pixmap
Error in dyn.load(x, as.logical(local), as.logical(now)) : 
        unable to load shared library '/usr/lib/R/library/rgdal/libs/rgdal.so':
  /usr/lib/R/library/rgdal/libs/rgdal.so: undefined symbol: DGifCloseFile
Error in library(rgdal) : .First.lib failed for 'rgdal'

This trial was conducted on R 2.1.0 on VineLinux 3.1.
$ rpm -q R gdal
$ ls /usr/lib/R/library/rgdal/libs/rgdal.so

It is happy to give me some advice.

More information about the R-sig-Geo mailing list