[R-sig-Fedora] installing 2.14.0 on fedora

José Matos jamatos at fc.up.pt
Mon Nov 7 15:10:18 CET 2011

On 11/06/2011 01:07 AM, Mark Leeds wrote:
> Hi All: I did what Gavin explained and I got the error
> "configure: error: --with-readline=yes (default) and headers/libs are not
> available".
> so then i read the R installation manual and it s says that I need libX11,
> libX11-devel, libXt and libXt-devel.
> It also mentioned libtiprc so I used the software manager and installed
> the  devels of above since they hadn't
> been installed.
> I don't know the mechanism that occurs when i do apply with th software
> manager but I tried configure again and I'm still getting the same error.
> Maybe wherever the devels got installed is not on my path ?
> That's the only thing I can think of but i'm not sure how to investigate
> that further. thanks.

Try yum-builddeps from the yum-utils package. From the manpage:

yum-builddep  is  a  program which installs the RPMs needed to build the
specified package.

José Matos

More information about the R-SIG-Fedora mailing list