[R-sig-Debian] ess 17.11-3 won't install on Ubuntu 16.04

Merkle, Edgar C. merklee @ending from mi@@ouri@edu
Tue Aug 21 15:12:36 CEST 2018

> On 20 August 2018 at 15:29, Eva Myers wrote:
> | Hello,
> | Attempting to install ess (17.11-3xenial0) on our Ubuntu 16.04 systems
> | is failing with an error message.
> This can happen. I (with my Debian hat on) had to make 17.11-3 because the
> ess package did not behave with Debian untable and Emacs 26.2. It does now.
> Changes can have side effects. Turn out that in this case 16.04 is
> affected. Your easiest recourse would be to not use this package, but the
> (much older) ESS from 16.04, or an older release (and then put it on 'hold'
> to supress updates).
> There will be a newer elpa-ess which may work for you (or not). You could try
> these:
>   http://dirk.eddelbuettel.com/tmp/elpa-ess_17.11-4_all.deb
>   http://dirk.eddelbuettel.com/tmp/ess_17.11-4_all.deb
> and you need both. "Works for me" on 18.04.  Not tested on 16.04. YMMV.

FWIW, I was able to fix this error in Ubuntu 16.04 by upgrading emacs to version 26.1. (I was previously using the version on the ubuntu repos, which was emacs 24.xx.)


More information about the R-SIG-Debian mailing list