[R-sig-Debian] Debian backport on Stretch?

Bill Harris bill_harris at facilitatedsystems.com
Sun Nov 19 00:17:16 CET 2017

I got a new laptop in September and installed Stretch (I had been using
Jessie), and I tried to follow the instructions on
https://cran.r-project.org/bin/linux/debian/, as I had multiple times in
the past: I added

deb http://cran.wustl.edu/bin/linux/debian stretch-cran34/

to the end of sources.list, I followed the rest of the above directions as
of early September, as best I recall, and I only got a partial
installation.  3.4.2 is installed, but I'm limited in what packages I can
load using aptitude (I haven't tried install.packages()).  From my reading,
this has to do with r-api-3 problems. If my problem isn't obvious, I'll be
glad to provide more details.

My question is there a successful and not too difficult way to install
3.4.2, or is deleting this R, deleting the wustl.edu backport entry, and
reinstalling R and its packages  from the standard Stretch repo the best
approach at this time?

If I should go back to the standard Stretch install, does that mean I need
to be especially cautious about installing packages with install.packages()
inside R, because that would get me a package that depended on r-api-34?  I
use a few packages like rstan, rstanarm, and brms that I don't see when I
do aptitude search, and I'm not sure what that means I should do.



	[[alternative HTML version deleted]]

More information about the R-SIG-Debian mailing list