[R-sig-Debian] Ubuntu 16.10 Yakkety Yak uses GCC 6 but -std=c++98 is missing

Dirk Eddelbuettel edd at debian.org
Sun Nov 13 00:00:58 CET 2016

On 12 November 2016 at 22:54, Kirill Müller wrote:

[... lots of stuff deleted ...]

| I noticed this because plogr logging crashed in dplyr (compiled with gcc 
| 6) right after upgrading to yakkety; I still had a gcc-5 built version 
| of Rcpp installed. As soon as I added -std, everything worked as before. 
| No minimal example, sorry. Don't we need "-std=c++98" in Makevars 
| anyway, even if it's just to avoid users using C++11 constructs and then 
| wondering why their packages fail on CRAN?

There is still no minimally preproducible example here; just a (pardon me
here) rambling description of a hasty system upgrade.

It is _somewhat common_ to have to recompile C++ shared objects when compiler
major versions change.

So I am unsure if we have actually demonstrated a bug here.


http://dirk.eddelbuettel.com | @eddelbuettel | edd at debian.org

More information about the R-SIG-Debian mailing list