[R-sig-Debian] Dependency failures on installing older R packages in Ubuntu

Jordan Dawe Jordan.Dawe at enernoc.com
Tue Feb 23 01:21:59 CET 2016

I’ve been trying to install the CRAN Ubuntu r-base-3.1.2 package on Ubuntu 14.04, and I keep getting the following failure:


vagrant at default-ubuntu-1404:/etc$ sudo apt-get install r-base=3.1.2-*

Reading package lists... Done

Building dependency tree

Reading state information... Done

Selected version '3.1.2-1trusty0' (CRAN:14.04/trusty [all]) for 'r-base'

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

 r-base : Depends: r-recommended (= 3.1.2-1trusty0) but 3.2.3-6trusty0 is to be installed

          Recommends: r-base-html but it is not going to be installed

          Recommends: r-doc-html but it is not going to be installed

E: Unable to correct problems, you have held broken packages.


In my apt/sources I have the line

deb     http://cran.fhcrc.org/bin/linux/ubuntu/ trusty/

Any ideas?


This email and any information disclosed in connection herewith, whether written or oral, is the property of EnerNOC, Inc. and is intended only for the person or entity to which it is addressed.  
This email may contain information that is privileged, confidential or otherwise protected from disclosure.  
Distributing or copying any information contained in this email to anyone other than the intended recipient is strictly prohibited.

	[[alternative HTML version deleted]]

More information about the R-SIG-Debian mailing list