[R-sig-Debian] rjags install on Ubuntu 10.04

John C Nash nashjc at uottawa.ca
Thu Sep 20 02:38:55 CEST 2012

I have been having trouble with rjags on Ubuntu 10.04

> library(rjags)
Loading required package: coda
Loading required package: lattice
linking to JAGS 3.2.0
module basemod loaded
Error : .onLoad failed in loadNamespace() for 'rjags', details:
  call: dyn.load(file)
  error: unable to load shared object '/usr/lib/JAGS/modules-3/bugs.so':
  /usr/lib/JAGS/modules-3/bugs.so: undefined symbol: fprec
Error: package/namespace load failed for ‘rjags’

> sessionInfo()
R version 2.15.1 (2012-06-22)
Platform: x86_64-pc-linux-gnu (64-bit)

 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8
 [7] LC_PAPER=C                 LC_NAME=C
 [9] LC_ADDRESS=C               LC_TELEPHONE=C

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

Also I have tried

> dyn.load("/usr/lib/JAGS/modules-3/bugs.so")
Error in dyn.load("/usr/lib/JAGS/modules-3/bugs.so") :
  unable to load shared object '/usr/lib/JAGS/modules-3/bugs.so':
  /usr/lib/JAGS/modules-3/bugs.so: undefined symbol: fprec

After several uninstalls and reinstalls of jags and rjags, I did (as superuser)

apt-get remove --purge r-base-core
apt-get autoremove

then reinstalled R, then rjags (the Michael Rutter PPA is in my sources list), i.e.,

apt-get install r-base-dev
apt-get install rjags

(I used the dev to make sure I got some of the tools etc.)

No joy.

On crunchbang stattler linux (under VirtualBox), things loaded fine. I haven't tried
actual computations though. (This is a debian squeeze variant.)

Suggestions welcome, especially about the fprec symbol above. I am planning to upgrade the
10.04 to something else soon, probably Mint Mate, but wanted to wait a few more weeks to
avoid doing this when having to travel.

Cheers, JN

More information about the R-SIG-Debian mailing list