[R-sig-Debian] rgl install failed...

Petar Milin pmilin at ff.uns.ac.rs
Sun May 17 11:32:37 CEST 2009

Hello, again!
Sorry for being tedious, that's because of having no experience enough, 
but I really want to learn.

Please, let me know what I am doing wrong now; I did following:

1. apt-get install -t unstable r-cran-rgl

2. then, from R, tried to do install.packages("rgl"), but that failed 
for same reasons as before:
    checking for X... no
    configure: error: X11 not found but required, configure aborted.
    ERROR: configuration failed for package ‘rgl’

3. then, I tried apt-get build-dep r-cran-rgl, and it went fine

4. finally, back to install.packages("rgl"), and now it failed for some 
other reasons:
    checking for GL/glu.h... yes
    checking for glEnd in -lGL... no
    configure: error: missing required library GL
    ERROR: configuration failed for package ‘rgl’

I think I did everything you said in your previous letters. Please, bear 
with me and let me learn and fix this.

Thank you. Best,

More information about the R-SIG-Debian mailing list