[R-sig-Debian] Updating packages after install of r-base 2.6.2: cant update rgl

Johannes Ranke jranke at uni-bremen.de
Thu Apr 10 08:43:23 CEST 2008

Hi Michael,

* Michael Friendly <friendly at yorku.ca> [080409 22:00]:
> Hi
> I just upgraded my R from stabel/etch from 2.4.x to 2.6.2 via
> sudo apt-get install r-base
> which worked fine, installing all dependencies

I suppose you put some CRAN mirror into your /etc/apt/sources.list?
>  From R, as root, I did
> update.packages()
> but a number of packages packages failed to install, either for missing 
> gfortran
> or missing dependencies.

Yes, you need to explicitly upgrade r-base-dev, too, if you want to
install packages from CRAN.
>  ...
> OK, I installed r-base-dev to get gfortran and other dependencies, then 
> tried
> update.packages() again.  This time only rgl failed, complaining about 
> missing X11:
> trying URL 'http://probability.ca/cran/src/contrib/rgl_0.77.tar.gz'
> Content type 'application/x-tar' length 803692 bytes (784 Kb)
> opened URL
> ==================================================
> downloaded 784 Kb
> * Installing *source* package 'rgl' ...
> checking for gcc... gcc -std=gnu99
> checking for C compiler default output file name... a.out
> checking whether the C compiler works... yes
> checking whether we are cross compiling... no
> checking for suffix of executables...
> checking for suffix of object files... o
> checking whether we are using the GNU C compiler... yes
> checking whether gcc -std=gnu99 accepts -g... yes
> checking for gcc -std=gnu99 option to accept ANSI C... none needed
> checking how to run the C preprocessor... gcc -std=gnu99 -E
> checking for gcc... (cached) gcc -std=gnu99
> checking whether we are using the GNU C compiler... (cached) yes
> checking whether gcc -std=gnu99 accepts -g... (cached) yes
> checking for gcc -std=gnu99 option to accept ANSI C... (cached) none needed
> checking for libpng-config... yes
> configure: using libpng-config
> configure: using libpng dynamic linkage
> checking for X... no
> configure: error: X11 not found but required, configure aborted.
> ERROR: configuration failed for package 'rgl'
> ** Removing '/usr/lib/R/site-library/rgl'
> ** Restoring previous '/usr/lib/R/site-library/rgl'

Ok, I just did this on one of my etch boxes with CRAN R (and X

  cecking for X... libraries , headers
  checking GL/gl.h usability... yes
  checking GL/gl.h presence... yes
  checking for GL/gl.h... yes
  checking GL/glu.h usability... yes
  checking GL/glu.h presence... yes
  checking for GL/glu.h... yes
  checking for glEnd in -lGL... yes
  checking for gluProject in -lGLU... yes
  configure: creating ./config.status
  config.status: creating src/Makevars

So it works over here... On another box, without OpenGL, it fails, as
one would expect. On a third box, where I have no X installed, it fails, 
too, with exactly the error message you quoted above.

Could you give us the output of

    apt-cache policy xserver-xorg-core

or just tell us if you have Xorg installed?

Best regards,


> Finally, I tried to install r-cran-rgl, but with no joy:
> euclid:~# apt-get install r-cran-rgl
> Reading package lists... Done
> Building dependency tree... Done
> r-cran-rgl is already the newest version.
> 0 upgraded, 0 newly installed, 0 to remove and 267 not upgraded.
> Can anyone suggest what is wrong and how to fix it?
> thanks,
> -Michael
> -- 
> Michael Friendly     Email: friendly at yorku.ca 
> Professor, Psychology Dept.
> York University      Voice: 416 736-5115 x66249 Fax: 416 736-5814
> 4700 Keele Street    http://www.math.yorku.ca/SCS/friendly.html
> Toronto, ONT  M3J 1P3 CANADA
> _______________________________________________
> R-SIG-Debian mailing list
> R-SIG-Debian at r-project.org
> https://stat.ethz.ch/mailman/listinfo/r-sig-debian

Dr. Johannes Ranke                 jranke at uni-bremen.de     Key ID: F649AF90
UFT Bremen, Leobenerstr. 1         +49 421 218 63373
D-28359 Bremen                     http://www.uft.uni-bremen.de/chemie/ranke

More information about the R-SIG-Debian mailing list