[R-sig-Debian] stable backport apt problem (solved)

Robert King robert.king at newcastle.edu.au
Tue May 2 19:03:54 CEST 2006


I started writing this email to describe a problem, then fixed it, so 
I'll display my ignorance anyway in case other people have a problem 
with it.

What happened was that I could get apt-get to upgrade the documentation 
packages, but not the others.

What I think was the problem was some remaining r-cran-* packages that 
are now in r-recommended.  These seemed to be blocking the upgrade of 
r-recommended, and hence r-base-core and thus r-base.

What I did was manually download r-base-core r-base-dev and 
r-recommended and install the .debs with dpkg.

Once this was done apt-get was able to fix the mess.

Here is some of the output I collected in the process.

This is the result of dpkg -l r-\* after the apt-get upgrade, which kept
back r-base r-base-dev r-base-core r-recommended

ii  r-base         2.1.0-1        GNU R statistical computing language
and env
ii  r-base-core    2.1.0-1        GNU R core of statistical computing
ii  r-base-dev     2.1.0-1        GNU R installation of auxiliary GNU R
ii  r-base-html    2.3.0-0sarge1  GNU R html docs for statistical
computing sy
ii  r-base-latex   2.3.0-0sarge1  GNU R LaTeX docs for statistical
computing s

[ some r-cran-* packages deleted ]

un  r-doc-html     <none>         (no description available)
un  r-doc-info     <none>         (no description available)
un  r-doc-pdf      <none>         (no description available)
ii  r-mathlib      2.1.0-1        GNU R standalone mathematics library
ii  r-recommended  2.1.0-1        GNU R collection of recommended

This is more sources.list

tolstoy:/etc/apt# cat sources.list
deb http://ftp.au.debian.org/debian/ stable main contrib non-free
deb http://ftp.au.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.au.debian.org/debian/ stable main contrib non-free

deb http://security.debian.org/ stable/updates main contrib non-free

#cran backports
deb http://cran.au.r-project.org/bin/linux/debian/ stable/

tolstoy:/etc/apt# apt-get install r-base-core=2.3.0-0sarge1
Reading Package Lists... Done
Building Dependency Tree... Done
E: Version '2.3.0-0sarge1' for 'r-base-core' was not found

tolstoy:~# wget
            => `r-base-core_2.3.0-0sarge1_i386.deb'
Resolving proxy.newcastle.edu.au...,
Connecting to proxy.newcastle.edu.au[]:8080... connected.
Proxy request sent, awaiting response... 200 OK
Length: 8,315,512 [application/x-debian-package]

100%[====================================>] 8,315,512      1.03M/s
ETA 00:00

02:20:02 (1.02 MB/s) - `r-base-core_2.3.0-0sarge1_i386.deb' saved

tolstoy:~# dpkg -i r-base-core_2.3.0-0sarge1_i386.deb
(Reading database ... 64541 files and directories currently installed.)
Preparing to replace r-base-core 2.1.0-1 (using
r-base-core_2.3.0-0sarge1_i386.deb) ...
Unpacking replacement r-base-core ...
Setting up r-base-core (2.3.0-0sarge1) ...

More information about the R-SIG-Debian mailing list